<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://mbu.ug/xmlrpc.php">
<!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-110865138-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics -->
<title>Marijuana is not a drug, it is just a flower - Bucha Man</title>

<!-- This site is optimized with the Yoast SEO plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Singer Bucha Man who was appointed as the presidential envoy on issues concerning the ghetto has maintained that marijuana is not a drug but just a flower."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Marijuana is not a drug, it is just a flower - Bucha Man" />
<meta property="og:description" content="Singer Bucha Man who was appointed as the presidential envoy on issues concerning the ghetto has maintained that marijuana is not a drug but just a flower." />
<meta property="og:url" content="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/" />
<meta property="og:site_name" content="MBU" />
<meta property="article:publisher" content="https://www.facebook.com/mbu.ug" />
<meta property="article:author" content="10529544_769261689792222_224470721_n" />
<meta property="article:tag" content="Bucha Man" />
<meta property="article:tag" content="Cannabis" />
<meta property="article:tag" content="Marijuana" />
<meta property="article:section" content="Gossip" />
<meta property="article:published_time" content="2020-02-28T10:51:30+00:00" />
<meta property="article:modified_time" content="2020-02-28T10:51:31+00:00" />
<meta property="og:updated_time" content="2020-02-28T10:51:31+00:00" />
<meta property="og:image" content="https://mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG-738x492.jpg" />
<meta property="og:image:secure_url" content="https://mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG-738x492.jpg" />
<meta property="og:image:width" content="738" />
<meta property="og:image:height" content="492" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Singer Bucha Man who was appointed as the presidential envoy on issues concerning the ghetto has maintained that marijuana is not a drug but just a flower." />
<meta name="twitter:title" content="Marijuana is not a drug, it is just a flower - Bucha Man" />
<meta name="twitter:site" content="@MBU" />
<meta name="twitter:image" content="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&#038;ssl=1" />
<meta name="twitter:creator" content="@MBU" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mbu.ug/#organization","name":"Mbu","url":"https://mbu.ug/","sameAs":["https://www.facebook.com/mbu.ug","https://www.instagram.com/mbu.ug/","https://twitter.com/MBU"],"logo":{"@type":"ImageObject","@id":"https://mbu.ug/#logo","inLanguage":"en-US","url":"https://i1.wp.com/mbu.ug/wp-content/uploads/2017/12/mbu_logo.png?fit=720%2C368&ssl=1","width":720,"height":368,"caption":"Mbu"},"image":{"@id":"https://mbu.ug/#logo"}},{"@type":"WebSite","@id":"https://mbu.ug/#website","url":"https://mbu.ug/","name":"MBU","inLanguage":"en-US","description":"Uganda&#039;s seriously fun stuff!","publisher":{"@id":"https://mbu.ug/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://mbu.ug/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&ssl=1","width":2048,"height":1365},{"@type":"WebPage","@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#webpage","url":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/","name":"Marijuana is not a drug, it is just a flower - Bucha Man","isPartOf":{"@id":"https://mbu.ug/#website"},"inLanguage":"en-US","primaryImageOfPage":{"@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#primaryimage"},"datePublished":"2020-02-28T10:51:30+00:00","dateModified":"2020-02-28T10:51:31+00:00","description":"Singer Bucha Man who was appointed as the presidential envoy on issues concerning the ghetto has maintained that marijuana is not a drug but just a flower."},{"@type":"Article","@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#article","isPartOf":{"@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#webpage"},"author":{"@id":"https://mbu.ug/#/schema/person/ddf4e65acba179e0da11a244e53a58e8"},"headline":"Marijuana is not a drug, it is just a flower &#8211; Bucha Man","datePublished":"2020-02-28T10:51:30+00:00","dateModified":"2020-02-28T10:51:31+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#webpage"},"publisher":{"@id":"https://mbu.ug/#organization"},"image":{"@id":"https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#primaryimage"},"keywords":"Bucha Man,Cannabis,Marijuana","articleSection":"Gossip","inLanguage":"en-US"},{"@type":["Person"],"@id":"https://mbu.ug/#/schema/person/ddf4e65acba179e0da11a244e53a58e8","name":"Solomon Mwesigwa","image":{"@type":"ImageObject","@id":"https://mbu.ug/#authorlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=96&d=mm&r=g","caption":"Solomon Mwesigwa"},"sameAs":["10529544_769261689792222_224470721_n"]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Feed" href="https://mbu.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Comments Feed" href="https://mbu.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Marijuana is not a drug, it is just a flower &#8211; Bucha Man Comments Feed" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-110865138-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-110865138-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mbu.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.3.2/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://mbu.ug/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.0.2' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mbu-fonts-css'  href='https://fonts.googleapis.com/css?family=Amiri%3A700%2C400%2C400italic%7CWork+Sans%3A400&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='mbu-style-css'  href='https://mbu.ug/wp-content/themes/mbu/style.css?ver=1.0' type='text/css' media='all' />
<style id='mbu-style-inline-css' type='text/css'>
.site-title, .site-description {display:none;}
		.site-branding {padding:0;}.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:300px;}
		#secondary .widget:nth-of-type(3n+1), #secondary .widget:nth-of-type(3n+1) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+2), #secondary .widget:nth-of-type(3n+2) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+3), #secondary .widget:nth-of-type(3n+3) .widget-title span {background-color:#f8f8f8;}
		#footer-widget, #footer-widget .widget-title span {background-color:#f8f8f8}.woocommerce .page-title {display:none;}@media screen and (min-width:978px )  {
		.menu-logo {float:left;}
		.navbar-navigation ul, .nav-social {display:block;}
		.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:500px;}
		}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.2.3/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.2.3/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/mbu.ug","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/mbu.ug\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"51315","token":"deebe9a5f2","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.0.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/jquery.jetpack-resize.min.js'></script>
<link rel='https://api.w.org/' href='https://mbu.ug/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mbu.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mbu.ug/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/' />
<link rel="alternate" type="application/json+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F02%2F28%2Fmarijuana-is-not-a-drug-it-is-just-a-flower-bucha-man%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F02%2F28%2Fmarijuana-is-not-a-drug-it-is-just-a-flower-bucha-man%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.3.1" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-0521644691090227",
          enable_page_level_ads: true
     });
</script>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/amp/"><link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=270%2C270&#038;ssl=1" />
</head>

<body class="post-template-default single single-post postid-51315 single-format-standard wp-custom-logo group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
				<nav id="top-navigation" class="navbar-navigation" role="navigation">

					<button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button>
										<button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button>
					<div id="search-panel" class="mbu-search-panel">
					    <button class="mbu-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
						<form role="search" method="get" class="search-form" action="https://mbu.ug/">
	<label>
			<span class="screen-reader-text">Search for: </span>
			<input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>   
	
					</div>

					<div class="menu-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					</div>
						<div class="social-menu-container"><ul id="social-menu" class="menu"><li id="menu-item-4692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li id="menu-item-4693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div><div class="menu-my-nav-container"><ul id="top-menu" class="menu"><li id="menu-item-1944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li id="menu-item-1933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li id="menu-item-1932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li id="menu-item-1941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li id="menu-item-2299" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li id="menu-item-2300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li id="menu-item-46421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div>		</nav><!-- #site-navigation -->

	    
	</header><!-- #masthead -->

	
	<div id="content" class="site-content container">
	<div id="top-widget" class="widget-area row" role="complementary">
	    <aside id="custom_html-6" class="widget_text widget widget_custom_html col-xs-12"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- mbu_leaderboard -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="5419942286"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>	</div><!-- #top-widget -->
<div class="row">
		<div id="primary" class="content-area col-lg-8">
		<main id="main" class="site-main row" role="main">

		
			
<article id="post-51315" class="col-xs-12 post-51315 post type-post status-publish format-standard has-post-thumbnail hentry category-gossip tag-bucha-man tag-cannabis tag-marijuana">


						<div class="category-list">
						<a href="https://mbu.ug/gossip/">Gossip</a>						</div>

	<header class="entry-header row">

		<h1 class="entry-title col-xs-12">Marijuana is not a drug, it is just a flower &#8211; Bucha Man</h1>		<div class="entry-meta  col-xs-12">
			<span class="byline"> <span class="author vcard"><img alt src="https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/d2806880636b1f788f465174f987517c?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript><a class="url fn n" href="https://mbu.ug/author/solomonmwesigwa/">Solomon Mwesigwa</a></span></span><div class="mbu-posted-on-sharing-wrapper"><span class="posted-on"><a href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/" rel="bookmark"><time class="entry-date published updated" datetime="2020-02-28T13:51:30+03:00">3 hours</time></a> ago</span><div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-51315" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-51315" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-51315" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->
			<div class="row">
			<div class="single-featured-image col-xs-12"   >
				<img width="2048" height="1365" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&amp;ssl=1" class="attachment-full size-full wp-post-image jetpack-lazy-image" alt="" data-attachment-id="44845" data-permalink="https://mbu.ug/2019/11/22/photos-all-hail-the-mayanjas-as-they-put-up-spirited-comedy-store-performance/buchaman-photo-by-comedy-store-ug/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&amp;ssl=1" data-orig-size="2048,1365" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Buchaman (Photo By Comedy Store UG)" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=448%2C299&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=738%2C492&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?w=2048&amp;ssl=1 2048w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=448%2C299&amp;ssl=1 448w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=768%2C512&amp;ssl=1 768w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=738%2C492&amp;ssl=1 738w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?w=1476&amp;ssl=1 1476w" data-lazy-sizes="(max-width: 2048px) 100vw, 2048px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			</div>
		</div>
		<div class="row">

	<div class="entry-content col-xs-12">
		
<p class="has-drop-cap">Singer Mark Bugembe a.k.a Bucha Man who was appointed as the presidential envoy on issues concerning the ghetto has maintained that marijuana is not a drug but just a mere flower that God put on planet earth.</p>



<p>According to Bucha Man, the nation should be educated about marijuana so that the public can learn the facts concerning the flower that many call a drug.</p>



<blockquote class="wp-block-quote"><p><strong><em>I think people need to be educated to the fact that marijuana is not a drug. Marijuana is a flower. Jah put it here.</em></strong></p><cite>Buch Man</cite></blockquote>



<figure class="wp-block-embed-facebook wp-block-embed is-type-rich is-provider-facebook"><div class="wp-block-embed__wrapper">
<div id="fb-root"></div><script async="1" defer="1" crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v6.0"></script><div class="fb-post" data-href="https://www.facebook.com/BuchamanOfficial/posts/1074678649564404" data-width="738"><blockquote cite="https://www.facebook.com/BuchamanOfficial/posts/1074678649564404" class="fb-xfbml-parse-ignore"><p>“I think people need to be educated to the fact that marijuana is not a drug. Marijuana is a flower. Jah put it here.</p>Posted by <a href="https://www.facebook.com/BuchamanOfficial/">Bucha Man</a> on&nbsp;<a href="https://www.facebook.com/BuchamanOfficial/posts/1074678649564404">Thursday, February 27, 2020</a></blockquote></div>
</div></figure>



<p>Through his socials, the <em>Lwaki Temumatila</em> singer went ahead and shared the health effects of marijuana that some term as &#8216;cannabis&#8217; as he stated a number of things that it can cure.</p>



<p>The former Firebase singer also praised the herb by revealing how it has hugely helped him live a life that is free from liver damage and being an alcoholic.</p>



<blockquote class="wp-block-quote"><p><strong><em> Smoking Herb is the only thing preventing me from a life of liver damage and being an alcoholic.</em></strong></p><cite>Bucha Man</cite></blockquote>



<figure class="wp-block-embed-facebook wp-block-embed is-type-rich is-provider-facebook"><div class="wp-block-embed__wrapper">
<div id="fb-root"></div><script async="1" defer="1" crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&amp;version=v6.0"></script><div class="fb-post" data-href="https://www.facebook.com/BuchamanOfficial/posts/1074716069560662" data-width="738"><blockquote cite="https://www.facebook.com/BuchamanOfficial/posts/1074716069560662" class="fb-xfbml-parse-ignore"><p>Smoking Herb is the only thing preventing me from a life of liver damage and being an alcoholic.Thank you Maryjane for being so good to me. #Weed Vs #Alcohol</p>Posted by <a href="https://www.facebook.com/BuchamanOfficial/">Bucha Man</a> on&nbsp;<a href="https://www.facebook.com/BuchamanOfficial/posts/1074716069560662">Thursday, February 27, 2020</a></blockquote></div>
</div></figure>



<p class="has-text-align-center"><strong>Read Also: </strong><a href="https://mbu.ug/2019/11/08/marijuana-is-not-a-drug-but-just-a-local-herb-buchaman/">&#8220;Marijuana is not a drug but just a local herb&#8221; &#8211; Bucha Man</a><strong><br></strong></p>
<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-140035613-51315-5e591e9e061e6' data-src='https://widgets.wp.com/likes/#blog_id=140035613&amp;post_id=51315&amp;origin=mbu.ug&amp;obj_id=140035613-51315-5e591e9e061e6' data-name='like-post-frame-140035613-51315-5e591e9e061e6'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			</div><!-- .entry-content -->

	<footer class="entry-footer col-xs-12">
		<div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-51315" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-51315" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-51315" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><span class="tags-links">Tagged: <a href="https://mbu.ug/tag/bucha-man/" rel="tag">Bucha Man</a>, <a href="https://mbu.ug/tag/cannabis/" rel="tag">Cannabis</a>, <a href="https://mbu.ug/tag/marijuana/" rel="tag">Marijuana</a></span>	</footer><!-- .entry-footer -->

	</div><!-- .row -->

</article><!-- #post-## -->

								<div class="mbu-related-posts col-xs-12">
						<h3><span>You May Also Like</span></h3>
						<div class="row">
											<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/" title="Herbert Shonga: I injected USD 25,000 in Dorothy&#8217;s plastic surgery" style="background: url( https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?fit=448%2C351&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/" title="Herbert Shonga: I injected USD 25,000 in Dorothy&#8217;s plastic surgery">Herbert Shonga: I injected USD 25,000 in Dorothy&#8217;s plastic surgery</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/02/28/king-saha-stings-bebe-cool-trashes-feeling-collabo-with-rudeboy/" title="King Saha stings Bebe Cool, trashes &#8216;Feeling&#8217; collabo with Rudeboy" style="background: url( https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/King-Saha-6-e1582816742748.jpg?fit=448%2C313&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/02/28/king-saha-stings-bebe-cool-trashes-feeling-collabo-with-rudeboy/" title="King Saha stings Bebe Cool, trashes &#8216;Feeling&#8217; collabo with Rudeboy">King Saha stings Bebe Cool, trashes &#8216;Feeling&#8217; collabo with Rudeboy</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/02/27/pia-pounds-fed-up-of-being-interviewed-about-sleeping-with-men/" title="Pia Pounds fed up of being interviewed about sleeping with men" style="background: url( https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Pia-Pounds.jpg?fit=448%2C448&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/02/27/pia-pounds-fed-up-of-being-interviewed-about-sleeping-with-men/" title="Pia Pounds fed up of being interviewed about sleeping with men">Pia Pounds fed up of being interviewed about sleeping with men</a></h4>
					</div>
										</div>
					</div>
				
			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/" rel="prev"><div class="mbu-previous-article">Previous article</div><div class="mbu-previous-article-title">Swangz Avenue&#8217;s Azawi premieres 5-track &#8216;LO FIT&#8217; EP</div></a></div><div class="nav-next"><a href="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/" rel="next"><div class="mbu-next-article">Next article</div><div class="mbu-next-article-title">Herbert Shonga: I injected USD 25,000 in Dorothy&#8217;s plastic surgery</div></a></div></div>
	</nav>
			
<div id="comments" class="comments-area col-md-12">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&#038;postid=51315&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.2.3&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=246273c3423ee1af1d12515db4676f437a8cf7bd#parent=https%3A%2F%2Fmbu.ug%2F2020%2F02%2F28%2Fmarijuana-is-not-a-drug-it-is-just-a-flower-bucha-man%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-lg-4" role="complementary">
	<div class="theiaStickySidebar">
	<aside id="facebook_likebox_by_fat-2" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/mbu.ug" data-width="350"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/mbu.ug"><a href="https://www.facebook.com/mbu.ug"></a></blockquote></div>
		</div>
		<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
		</aside><aside id="text-4" class="widget widget_text">			<div class="textwidget"><p><a class="twitter-timeline" data-height="300" href="https://twitter.com/MBU?ref_src=twsrc%5Etfw">Tweets by MBU</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
</div>
		</aside>
<aside id="wpp-16" class="widget popular-posts">
<h2 class="widget-title"><span>Most Popular</span></h2>
<!-- WordPress Popular Posts -->
<ol class="wpp-list"><li><a class="wpp-image" href="https://mbu.ug/2020/02/28/jose-chameleone-scores-12-points-in-2019-uace-finals/" title="Jose Chameleone scores 12 points in 2019 UACE finals" style="background:url(https://i0.wp.com/mbu.ug/wp-content/uploads/2020/01/jose-chameleone.jpg?fit=448%2C448&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/02/28/jose-chameleone-scores-12-points-in-2019-uace-finals/" title="Jose Chameleone scores 12 points in 2019 UACE finals">Jose Chameleone scores 12 points in 2019 UACE finals</a></h2></div></li><li><a class="wpp-image" href="https://mbu.ug/2020/02/28/king-saha-stings-bebe-cool-trashes-feeling-collabo-with-rudeboy/" title="King Saha stings Bebe Cool, trashes &#039;Feeling&#039; collabo with Rudeboy" style="background:url(https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/King-Saha-6-e1582816742748.jpg?fit=448%2C313&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/02/28/king-saha-stings-bebe-cool-trashes-feeling-collabo-with-rudeboy/" title="King Saha stings Bebe Cool, trashes &#039;Feeling&#039; collabo with Rudeboy">King Saha stings Bebe Cool, trashes 'Feeling' collabo with Rudeboy</a></h2></div></li><li><a class="wpp-image" href="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/" title="Swangz Avenue&#039;s Azawi premieres 5-track &#039;LO FIT&#039; EP" style="background:url(https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?fit=448%2C299&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/" title="Swangz Avenue&#039;s Azawi premieres 5-track &#039;LO FIT&#039; EP">Swangz Avenue's Azawi premieres 5-track 'LO FIT' EP</a></h2></div></li></ol>
</aside>
		<aside id="fat-recent-posts-3" class="widget fat_widget_recent_entries">		<h2 class="widget-title"><span>Recent Posts</span></h2>		<ul>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="51413" data-permalink="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/herbert-dorothy/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?fit=625%2C489&amp;ssl=1" data-orig-size="625,489" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Herbert &#8211; Dorothy" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?fit=448%2C351&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?fit=625%2C489&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/02/Herbert-Dorothy-e1582886538821.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/02/28/herbert-shonga-i-injected-usd-25000-in-dorothys-plastic-surgery/">Herbert Shonga: I injected USD 25,000 in Dorothy&#8217;s plastic surgery</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="44845" data-permalink="https://mbu.ug/2019/11/22/photos-all-hail-the-mayanjas-as-they-put-up-spirited-comedy-store-performance/buchaman-photo-by-comedy-store-ug/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=2048%2C1365&amp;ssl=1" data-orig-size="2048,1365" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Buchaman (Photo By Comedy Store UG)" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=448%2C299&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?fit=738%2C492&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2019/11/Buchaman-Photo-By-Comedy-Store-UG.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/02/28/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man/">Marijuana is not a drug, it is just a flower &#8211; Bucha Man</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/"><img width="80" height="80" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="51406" data-permalink="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/azawi-vinka-nwagi/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?fit=1080%2C720&amp;ssl=1" data-orig-size="1080,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="azawi vinka nwagi" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?fit=448%2C299&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?fit=738%2C492&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?resize=80%2C80&amp;ssl=1 80w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/azawi-vinka-nwagi.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/02/28/swangz-avenues-azawi-premieres-5-track-lo-fit-ep/">Swangz Avenue&#8217;s Azawi premieres 5-track &#8216;LO FIT&#8217; EP</a></h3>
	      				      </div>
			</li>
				</ul>
		</aside>		<aside id="fat_widget_instagram-3" class="widget fat__widget-instagram"><h3 class="screen-reader-text">Instagram</h3><div class="fat__instagram-container"><span class="error">Nothing to show.</span></div></aside>	</div>
</div><!-- #secondary -->
</div><!-- .row -->

	</div><!-- #content -->

			<div id="left-sidebar" class="left-sidebar-area">
				<div class="left-sidebar-content">
					<div class="left-header">
					<div class="left-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					<button class="left-sidebar-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
					</div>
					</div>
					<nav id="site-navigation" class="main-navigation" role="navigation">
					<div class="menu-my-nav-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div><div class="social-menu-container"><ul id="social-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div>					</nav><!-- #site-navigation -->
					
<div id="tetriary" class="left-widget-area" role="complementary">
	<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><hr/></div></aside></div><!-- #tetriary -->
					<div class="site-info">
			<p>© 2018 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>					</div><!-- .site-info -->
				</div>
			</div>
		<div class="left-sidebar-bg">
		</div><!-- .left-sidebar-bg -->
					<div id="footer-widget" class="widget-area" role="complementary">
		<div class="container">
			<div class="row">
		    			</div>
		</div>
	</div><!-- #footer-widget -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
		<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><p>© 2018 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mbu.ug\/2020\/02\/28\/marijuana-is-not-a-drug-it-is-just-a-flower-bucha-man\/":51315};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/slick/slick.min.js?ver=20150828'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/theia-sticky-sidebar.min.js?ver=1.2.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/effect.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/jquery/ui/effect-slide.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mbu = {"loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","LoginButtonText":"Login","RegisterButtonText":"Create An Account","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/mbu.ug\/wp-content\/themes\/mbu","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/mbu.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/skip-link-focus-fix.min.js?ver=20130115'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.3.2/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.2.3/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202009#ver=202009' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=51315&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=246273c3423ee1af1d12515db4676f437a8cf7bd#parent=https%3A%2F%2Fmbu.ug%2F2020%2F02%2F28%2Fmarijuana-is-not-a-drug-it-is-just-a-flower-bucha-man%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=51315&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.2.3&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=246273c3423ee1af1d12515db4676f437a8cf7bd#parent=https%3A%2F%2Fmbu.ug%2F2020%2F02%2F28%2Fmarijuana-is-not-a-drug-it-is-just-a-flower-bucha-man%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202009.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.2.3',blog:'140035613',post:'51315',tz:'3',srv:'mbu.ug'} ]);
	_stq.push([ 'clickTrackerInit', '140035613', '51315' ]);
</script>

</body>
</html>
