<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://mbu.ug/xmlrpc.php">
<!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-110865138-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics -->

	<!-- This site is optimized with the Yoast SEO plugin v14.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Navio drops &#039;Bangi&#039; visuals featuring Flex d&#039;Paper and Daddy Andre</title>
	<meta name="description" content="Navio features another talented rapper Flex d&#039;Paper and super Producer and Singer Daddy Andre on his latest release dubbed &#039;Bangi&#039;." />
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Navio drops &#039;Bangi&#039; visuals featuring Flex d&#039;Paper and Daddy Andre" />
	<meta property="og:description" content="Navio features another talented rapper Flex d&#039;Paper and super Producer and Singer Daddy Andre on his latest release dubbed &#039;Bangi&#039;." />
	<meta property="og:url" content="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/" />
	<meta property="og:site_name" content="MBU" />
	<meta property="article:publisher" content="https://www.facebook.com/mbu.ug" />
	<meta property="article:author" content="https://www.facebook.com/josh.ruby" />
	<meta property="article:published_time" content="2020-06-05T06:39:39+00:00" />
	<meta property="article:modified_time" content="2020-06-05T06:39:40+00:00" />
	<meta property="og:image" content="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=851%2C440&#038;ssl=1" />
	<meta property="og:image:width" content="851" />
	<meta property="og:image:height" content="440" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@iamjoshruby" />
	<meta name="twitter:site" content="@MBU" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mbu.ug/#organization","name":"Mbu","url":"https://mbu.ug/","sameAs":["https://www.facebook.com/mbu.ug","https://www.instagram.com/mbu.ug/","https://twitter.com/MBU"],"logo":{"@type":"ImageObject","@id":"https://mbu.ug/#logo","inLanguage":"en-US","url":"https://i1.wp.com/mbu.ug/wp-content/uploads/2017/12/mbu_logo.png?fit=720%2C368&ssl=1","width":720,"height":368,"caption":"Mbu"},"image":{"@id":"https://mbu.ug/#logo"}},{"@type":"WebSite","@id":"https://mbu.ug/#website","url":"https://mbu.ug/","name":"MBU","description":"Uganda&#039;s seriously fun stuff!","publisher":{"@id":"https://mbu.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://mbu.ug/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=851%2C440&ssl=1","width":851,"height":440},{"@type":"WebPage","@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#webpage","url":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/","name":"Navio drops 'Bangi' visuals featuring Flex d'Paper and Daddy Andre","isPartOf":{"@id":"https://mbu.ug/#website"},"primaryImageOfPage":{"@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#primaryimage"},"datePublished":"2020-06-05T06:39:39+00:00","dateModified":"2020-06-05T06:39:40+00:00","description":"Navio features another talented rapper Flex d'Paper and super Producer and Singer Daddy Andre on his latest release dubbed 'Bangi'.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/"]}]},{"@type":"Article","@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#article","isPartOf":{"@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#webpage"},"author":{"@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a"},"headline":"Navio drops &#8216;Bangi&#8217; visuals featuring Flex d&#8217;Paper and Daddy Andre","datePublished":"2020-06-05T06:39:39+00:00","dateModified":"2020-06-05T06:39:40+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#webpage"},"publisher":{"@id":"https://mbu.ug/#organization"},"image":{"@id":"https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#primaryimage"},"keywords":"Bangi,Daddy Andre,Flex D'Paper,Navio,video","articleSection":"Music","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#respond"]}]},{"@type":["Person"],"@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a","name":"Josh Ruby","image":{"@type":"ImageObject","@id":"https://mbu.ug/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&d=mm&r=g","caption":"Josh Ruby"},"description":"Simple, Patient, Articulate; but all with a limit. I love writing, reading, interacting with anyone with leads in Ugandan entertainment news.","sameAs":["https://www.facebook.com/josh.ruby","https://www.instagram.com/iamjoshruby/","https://twitter.com/iamjoshruby","https://www.youtube.com/channel/UCMZgCJ0KrQb7JBKobh2OjvQ","https://www.tumblr.com/blog/joshruby"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Feed" href="https://mbu.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Comments Feed" href="https://mbu.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Navio drops &#8216;Bangi&#8217; visuals featuring Flex d&#8217;Paper and Daddy Andre Comments Feed" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/feed/" />
<!-- This site uses the Google Analytics by MonsterInsights plugin v7.10.4 - Using Analytics tracking - https://www.monsterinsights.com/ -->
<script type="text/javascript" data-cfasync="false">
	var mi_version         = '7.10.4';
	var mi_track_user      = true;
	var mi_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-110865138-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}
	
	if ( mi_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

		__gaTracker('create', 'UA-110865138-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('require', 'displayfeatures');
		__gaTracker('send','pageview');
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + mi_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
					})();
		}
</script>
<!-- / Google Analytics by MonsterInsights -->
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mbu.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.4.1"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.4.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://mbu.ug/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' type='text/css' media='all' />
<link crossorigin="anonymous" rel='stylesheet' id='mbu-fonts-css'  href='https://fonts.googleapis.com/css?family=Amiri%3A700%2C400%2C400italic%7CWork+Sans%3A400&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='mbu-style-css'  href='https://mbu.ug/wp-content/themes/mbu/style.css?ver=1.0' type='text/css' media='all' />
<style id='mbu-style-inline-css' type='text/css'>
.site-title, .site-description {display:none;}
		.site-branding {padding:0;}.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:300px;}
		#secondary .widget:nth-of-type(3n+1), #secondary .widget:nth-of-type(3n+1) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+2), #secondary .widget:nth-of-type(3n+2) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+3), #secondary .widget:nth-of-type(3n+3) .widget-title span {background-color:#f8f8f8;}
		#footer-widget, #footer-widget .widget-title span {background-color:#f8f8f8}.woocommerce .page-title {display:none;}@media screen and (min-width:978px )  {
		.menu-logo {float:left;}
		.navbar-navigation ul, .nav-social {display:block;}
		.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:500px;}
		}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/8.5/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/8.5/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[]","home_url":"https:\/\/mbu.ug","hash_tracking":"false"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend.min.js?ver=7.10.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/mbu.ug\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"57639","token":"c9a88ab926","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/jquery-migrate.min.js'></script>
<link rel='https://api.w.org/' href='https://mbu.ug/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mbu.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mbu.ug/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.1" />
<link rel='shortlink' href='https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/' />
<link rel="alternate" type="application/json+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.8.1" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-0521644691090227",
          enable_page_level_ads: true
     });
</script>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//jetpack.wordpress.com'/>
<link rel='dns-prefetch' href='//s1.wp.com'/>
<link rel='dns-prefetch' href='//s2.wp.com'/>
<link rel='dns-prefetch' href='//public-api.wordpress.com'/>
<link rel='dns-prefetch' href='//c0.wp.com'/>
<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/amp/"><link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=270%2C270&#038;ssl=1" />
</head>

<body class="post-template-default single single-post postid-57639 single-format-standard wp-custom-logo group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
				<nav id="top-navigation" class="navbar-navigation" role="navigation">

					<button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button>
										<button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button>
					<div id="search-panel" class="mbu-search-panel">
					    <button class="mbu-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
						<form role="search" method="get" class="search-form" action="https://mbu.ug/">
	<label>
			<span class="screen-reader-text">Search for: </span>
			<input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>   
	
					</div>

					<div class="menu-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					</div>
						<div class="social-menu-container"><ul id="social-menu" class="menu"><li id="menu-item-4692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li id="menu-item-4693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div><div class="menu-my-nav-container"><ul id="top-menu" class="menu"><li id="menu-item-1944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li id="menu-item-1933" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li id="menu-item-1932" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li id="menu-item-1941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li id="menu-item-2299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li id="menu-item-2300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li id="menu-item-46421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div>		</nav><!-- #site-navigation -->

	    
	</header><!-- #masthead -->

	
	<div id="content" class="site-content container">
	<div id="top-widget" class="widget-area row" role="complementary">
	    <aside id="media_image-2" class="widget widget_media_image col-xs-12"><a href="https://bit.ly/corona-mbu" target="_blank" rel="noopener noreferrer"><img width="970" height="90" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_leaderboard.gif?fit=970%2C90&amp;ssl=1" class="image wp-image-57334  attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="57334" data-permalink="https://mbu.ug/stigma_leaderboard/" data-orig-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_leaderboard.gif?fit=970%2C90&amp;ssl=1" data-orig-size="970,90" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="stigma_leaderboard" data-image-description="" data-medium-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_leaderboard.gif?fit=448%2C42&amp;ssl=1" data-large-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_leaderboard.gif?fit=738%2C68&amp;ssl=1" data-lazy-src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_leaderboard.gif?fit=970%2C90&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></aside>	</div><!-- #top-widget -->
<div class="row">
		<div id="primary" class="content-area col-lg-8">
		<main id="main" class="site-main row" role="main">

		
			
<article id="post-57639" class="col-xs-12 post-57639 post type-post status-publish format-standard has-post-thumbnail hentry category-music tag-bangi tag-daddy-andre tag-flex-dpaper tag-navio tag-video">


						<div class="category-list">
						<a href="https://mbu.ug/music/">Music</a>						</div>

	<header class="entry-header row">

		<h1 class="entry-title col-xs-12">Navio drops &#8216;Bangi&#8217; visuals featuring Flex d&#8217;Paper and Daddy Andre</h1>		<div class="entry-meta  col-xs-12">
			<span class="byline"> <span class="author vcard"><img alt src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" data-lazy-srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' /></noscript><a class="url fn n" href="https://mbu.ug/author/joshualubanga/">Josh Ruby</a></span></span><div class="mbu-posted-on-sharing-wrapper"><span class="posted-on"><a href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/" rel="bookmark"><time class="entry-date published updated" datetime="2020-06-05T09:39:39+03:00">10 hours</time></a> ago</span><div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-57639" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-57639" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-57639" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->
			<div class="row">
			<div class="single-featured-image col-xs-12"   >
				<img width="851" height="440" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=851%2C440&amp;ssl=1" class="attachment-full size-full wp-post-image jetpack-lazy-image" alt="" data-attachment-id="57654" data-permalink="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/navio-daddy-andre-flex-dpaper/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=851%2C440&amp;ssl=1" data-orig-size="851,440" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Navio, Daddy Andre, Flex d&#8217;Paper" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=448%2C232&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=738%2C382&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?w=851&amp;ssl=1 851w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?resize=448%2C232&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?resize=738%2C382&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?resize=768%2C397&amp;ssl=1 768w" data-lazy-sizes="(max-width: 851px) 100vw, 851px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-Daddy-Andre-Flex-dPaper.png?fit=851%2C440&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			</div>
		</div>
		<div class="row">

	<div class="entry-content col-xs-12">
		
<p class="has-drop-cap">Widely recognized as the most exposed Rapper across East Africa, Navio features another talented rapper Flex d&#8217;Paper and super Producer and Singer Daddy Andre on his latest release dubbed &#8216;Bangi&#8217;.</p>



<p>There are not many times before that a collective with such vivid and varying Ugandan talent has come together on one project.</p>



<figure class="wp-block-image size-full"><img data-attachment-id="57644" data-permalink="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/navio-5-2/" data-orig-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?fit=640%2C960&amp;ssl=1" data-orig-size="640,960" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Navio (5)" data-image-description="" data-medium-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?fit=448%2C672&amp;ssl=1" data-large-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?fit=640%2C960&amp;ssl=1" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?w=738&#038;ssl=1" alt="" class="wp-image-57644" srcset="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?w=640&amp;ssl=1 640w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-5.jpg?resize=448%2C672&amp;ssl=1 448w" sizes="(max-width: 640px) 100vw, 640px" data-recalc-dims="1" /></figure>



<p>Navio with the Top selling Ugandan Album of the year so far, “Strength In Numbers”, has literally been trending throughout the last few months. If it wasn’t the album and it’s impact, it was the energetic performances on the Saturday TV Shows or hosting the first ever Online Launch Concert done in Africa.</p><aside class="scaip scaip-1    "><aside id="media_image-3" class="widget_media_image clearfix"><a href="https://bit.ly/corona-mbu" target="_blank" rel="noopener noreferrer"><img width="300" height="250" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_sidebar.gif?fit=300%2C250&amp;ssl=1" class="image wp-image-57335  attachment-full size-full jetpack-lazy-image" alt="" style="max-width: 100%; height: auto;" data-attachment-id="57335" data-permalink="https://mbu.ug/stigma_sidebar/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_sidebar.gif?fit=300%2C250&amp;ssl=1" data-orig-size="300,250" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="stigma_sidebar" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_sidebar.gif?fit=300%2C250&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_sidebar.gif?fit=300%2C250&amp;ssl=1" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/05/stigma_sidebar.gif?fit=300%2C250&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a></aside></aside>



<p>Daddy Andre and Flex d’Paper’s rise to notoriety has been one way&#8230; UP! They have gained ground in unpredictable ways with Andre becoming a household name and Flex achieving the Video of the Year accolade at the UG Hip Hop Awards.</p>



<figure class="wp-block-image size-full"><img data-attachment-id="57653" data-permalink="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/navio-and-flex-dpaper-3/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?fit=820%2C960&amp;ssl=1" data-orig-size="820,960" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Navio and Flex d&#8217;Paper (3)" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?fit=448%2C524&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?fit=738%2C864&amp;ssl=1" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?w=738&#038;ssl=1" alt="" class="wp-image-57653" srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?w=820&amp;ssl=1 820w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?resize=448%2C524&amp;ssl=1 448w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?resize=738%2C864&amp;ssl=1 738w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Navio-and-Flex-dPaper-3.jpg?resize=768%2C899&amp;ssl=1 768w" sizes="(max-width: 738px) 100vw, 738px" data-recalc-dims="1" /></figure>



<p>“Bangi” is Navio&#8217;s first official single of the year and the first to be pushed after the album “<a rel="noreferrer noopener" href="https://mbu.ug/2020/04/10/navio-set-to-launch-15-track-strength-in-numbers-album-online/" target="_blank">Strength In Numbers</a>” has come out. The song was produced by Icon Studio’s own Mio Made.</p>



<p>Sasha Vybz who is the most sought after Director in EA right now- outdid himself in the video, with Pineapple Bay for the first time in Lake Victoria acting as the backdrop for this amazing video. The MV Vanessa was the boat that was featured and the waves of Lake Victoria around her bow made for a quality ride that could be felt in the video.</p><aside class="scaip scaip-2    "></aside>



<figure class="wp-block-embed-youtube wp-block-embed is-type-video is-provider-youtube wp-embed-aspect-16-9 wp-has-aspect-ratio"><div class="wp-block-embed__wrapper">
<iframe title="BANGI- NAVIO ft DADDY ANDRE &amp; FLEX D&#039; PAPER" width="738" height="415" src="https://www.youtube.com/embed/9d8j-ABZAn8?feature=oembed" frameborder="0" allow="accelerometer; autoplay; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe>
</div></figure>



<p class="has-text-align-center"><strong>Read Also: </strong><a rel="noreferrer noopener" href="https://mbu.ug/2020/05/27/sas-mafikizolo-cindy-pallaso-navio-mugabi-set-for-club-beatz-finale/" target="_blank">SA&#8217;s Mafikizolo, Cindy Sanyu, Pallaso, Navio, Kenneth Mugabi set for Club Beatz finale</a></p>
<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-140035613-57639-5eda726e61fdf' data-src='https://widgets.wp.com/likes/#blog_id=140035613&amp;post_id=57639&amp;origin=mbu.ug&amp;obj_id=140035613-57639-5eda726e61fdf' data-name='like-post-frame-140035613-57639-5eda726e61fdf'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>			</div><!-- .entry-content -->

	<footer class="entry-footer col-xs-12">
		<div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-57639" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-57639" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-57639" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><span class="tags-links">Tagged: <a href="https://mbu.ug/tag/bangi/" rel="tag">Bangi</a>, <a href="https://mbu.ug/tag/daddy-andre/" rel="tag">Daddy Andre</a>, <a href="https://mbu.ug/tag/flex-dpaper/" rel="tag">Flex D'Paper</a>, <a href="https://mbu.ug/tag/navio/" rel="tag">Navio</a>, <a href="https://mbu.ug/tag/video/" rel="tag">video</a></span>	</footer><!-- .entry-footer -->

	</div><!-- .row -->

</article><!-- #post-## -->

								<div class="mbu-related-posts col-xs-12">
						<h3><span>You May Also Like</span></h3>
						<div class="row">
											<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/06/04/pallaso-links-up-with-zex-bilangilangi-on-wikid-video-alert/" title="Pallaso links up with Zex Bilangilangi on &#8216;Wikid&#8217; | VIDEO ALERT" style="background: url( https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Zex-Bilangilangi-6-1-e1591266496981.jpg?fit=448%2C423&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/06/04/pallaso-links-up-with-zex-bilangilangi-on-wikid-video-alert/" title="Pallaso links up with Zex Bilangilangi on &#8216;Wikid&#8217; | VIDEO ALERT">Pallaso links up with Zex Bilangilangi on &#8216;Wikid&#8217; | VIDEO ALERT</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/06/03/sheebah-karungi-jumps-on-crysto-pandas-kyoyina-omanya-remix/" title="Sheebah Karungi jumps on Crysto Panda&#8217;s &#8216;Kyoyina Omanya&#8217; (Remix)" style="background: url( https://i0.wp.com/mbu.ug/wp-content/uploads/2019/10/sheebah-k.jpg?fit=448%2C448&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/06/03/sheebah-karungi-jumps-on-crysto-pandas-kyoyina-omanya-remix/" title="Sheebah Karungi jumps on Crysto Panda&#8217;s &#8216;Kyoyina Omanya&#8217; (Remix)">Sheebah Karungi jumps on Crysto Panda&#8217;s &#8216;Kyoyina Omanya&#8217; (Remix)</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/06/02/jim-nola-mc-accuses-feffe-bussi-of-plagiarizing-his-nkwe-za-walumbe-song/" title="Jim Nola MC accuses Feffe Bussi of plagiarizing his &#8216;Nkwe Za Walumbe&#8217; song" style="background: url( https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Jim-Nola-MC.jpg?fit=448%2C455&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/06/02/jim-nola-mc-accuses-feffe-bussi-of-plagiarizing-his-nkwe-za-walumbe-song/" title="Jim Nola MC accuses Feffe Bussi of plagiarizing his &#8216;Nkwe Za Walumbe&#8217; song">Jim Nola MC accuses Feffe Bussi of plagiarizing his &#8216;Nkwe Za Walumbe&#8217; song</a></h4>
					</div>
										</div>
					</div>
				
			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://mbu.ug/2020/06/04/tanasha-donna-accuses-diamond-platnumz-of-being-a-deadbeat-dad/" rel="prev"><div class="mbu-previous-article">Previous article</div><div class="mbu-previous-article-title">Tanasha Donna accuses Diamond Platnumz of being a &#8216;deadbeat&#8217; dad</div></a></div><div class="nav-next"><a href="https://mbu.ug/2020/06/05/we-were-not-social-media-artistes-in-our-times-but-we-have-to-adapt-rabadaba/" rel="next"><div class="mbu-next-article">Next article</div><div class="mbu-next-article-title">We were not social media artistes in our times but we have to adapt &#8211; Rabadaba</div></a></div></div>
	</nav>
			
<div id="comments" class="comments-area col-md-12">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/06/05/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&#038;postid=57639&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=8.5&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=49de95771d7f8d92ffea49ce3f05fe760b781cf6#parent=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-lg-4" role="complementary">
	<div class="theiaStickySidebar">
	<aside id="facebook_likebox_by_fat-2" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/mbu.ug" data-width="350"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/mbu.ug"><a href="https://www.facebook.com/mbu.ug"></a></blockquote></div>
		</div>
		<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
		</aside><aside id="text-4" class="widget widget_text">			<div class="textwidget"><p><a class="twitter-timeline" data-height="300" href="https://twitter.com/MBU?ref_src=twsrc%5Etfw">Tweets by MBU</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
</div>
		</aside>
<aside id="wpp-16" class="widget popular-posts">
<h2 class="widget-title"><span>Most Popular</span></h2>
<!-- WordPress Popular Posts -->
<ol class="wpp-list"><li><a class="wpp-image" href="https://mbu.ug/2020/06/05/im-not-the-ssalongo-but-ive-been-dating-sasha-ferguson-for-6-years-canary-mugume/" title="I&#039;m not the Ssalongo but I&#039;ve been dating Sasha Ferguson for 6 years - Canary Mugume" style="background:url(https://i2.wp.com/mbu.ug/wp-content/uploads/2019/11/Sasha-Ferguson-Canary-Mugume.jpeg?fit=448%2C299&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/06/05/im-not-the-ssalongo-but-ive-been-dating-sasha-ferguson-for-6-years-canary-mugume/" title="I&#039;m not the Ssalongo but I&#039;ve been dating Sasha Ferguson for 6 years - Canary Mugume">I'm not the Ssalongo but I've been dating Sasha Ferguson for 6 years - Canary Mugume</a></h2></div></li><li><a class="wpp-image" href="https://mbu.ug/2020/06/05/abryanz-opens-up-on-lgbt-asfas-sponsorship-allegations/" title="Abryanz opens up on LGBT ASFAs sponsorship allegations" style="background:url(https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?fit=448%2C373&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/06/05/abryanz-opens-up-on-lgbt-asfas-sponsorship-allegations/" title="Abryanz opens up on LGBT ASFAs sponsorship allegations">Abryanz opens up on LGBT ASFAs sponsorship allegations</a></h2></div></li><li><a class="wpp-image" href="https://mbu.ug/2020/06/05/i-dont-fear-you-ill-drag-you-to-your-level-alicia-bosschic-threatens-bad-black/" title="I don&#039;t fear you, I&#039;ll drag you to your level  - Alicia Bosschic threatens Bad Black" style="background:url(https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Alicia-Bosschic.jpg?fit=448%2C448&#038;ssl=1) no-repeat center;background-size: cover;"></a><div class="wpp-content"><h2 class="wpp-post-title"><a href="https://mbu.ug/2020/06/05/i-dont-fear-you-ill-drag-you-to-your-level-alicia-bosschic-threatens-bad-black/" title="I don&#039;t fear you, I&#039;ll drag you to your level  - Alicia Bosschic threatens Bad Black">I don't fear you, I'll drag you to your level  - Alicia Bosschic threatens Bad Black</a></h2></div></li></ol>
</aside>
		<aside id="fat-recent-posts-3" class="widget fat_widget_recent_entries">		<h2 class="widget-title"><span>Recent Posts</span></h2>		<ul>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/06/05/ive-no-beef-with-bebe-cool-i-only-disagree-with-some-of-his-opinions-mikie-wine/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="57715" data-permalink="https://mbu.ug/2020/06/05/ive-no-beef-with-bebe-cool-i-only-disagree-with-some-of-his-opinions-mikie-wine/mikie-wine-2/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?fit=600%2C300&amp;ssl=1" data-orig-size="600,300" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Mikie Wine (2)" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?fit=448%2C224&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?fit=600%2C300&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/06/Mikie-Wine-2.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/06/05/ive-no-beef-with-bebe-cool-i-only-disagree-with-some-of-his-opinions-mikie-wine/">I&#8217;ve no beef with Bebe Cool, I only disagree with some of his opinions &#8211; Mikie Wine</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/06/05/george-floyd-ang3lina-rickman-manrick-join-celebrities-all-over-the-world-in-condemning-racism/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="53757" data-permalink="https://mbu.ug/2020/04/09/ang3lina-urges-fans-not-to-underestimate-covid-19-after-losing-grandmother/ang3lina-rickman-2/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?fit=960%2C592&amp;ssl=1" data-orig-size="960,592" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="ang3lina rickman" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?fit=448%2C276&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?fit=738%2C455&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/04/ang3lina-rickman-e1591369714515.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/06/05/george-floyd-ang3lina-rickman-manrick-join-celebrities-all-over-the-world-in-condemning-racism/">George Floyd: Ang3lina, Rickman Manrick join celebrities all over the world in condemning racism</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/06/05/abryanz-opens-up-on-lgbt-asfas-sponsorship-allegations/"><img width="80" height="80" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" data-attachment-id="57704" data-permalink="https://mbu.ug/2020/06/05/abryanz-opens-up-on-lgbt-asfas-sponsorship-allegations/abryanz-5/" data-orig-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?fit=1080%2C899&amp;ssl=1" data-orig-size="1080,899" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Abryanz" data-image-description="" data-medium-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?fit=448%2C373&amp;ssl=1" data-large-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?fit=738%2C614&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/06/Abryanz.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/06/05/abryanz-opens-up-on-lgbt-asfas-sponsorship-allegations/">Abryanz opens up on LGBT ASFAs sponsorship allegations</a></h3>
	      				      </div>
			</li>
				</ul>
		</aside>		<aside id="fat_widget_instagram-3" class="widget fat__widget-instagram"><h3 class="screen-reader-text">Instagram</h3><div class="fat__instagram-container"><span class="error">Nothing to show.</span></div></aside>	</div>
</div><!-- #secondary -->
</div><!-- .row -->

	</div><!-- #content -->

			<div id="left-sidebar" class="left-sidebar-area">
				<div class="left-sidebar-content">
					<div class="left-header">
					<div class="left-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					<button class="left-sidebar-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
					</div>
					</div>
					<nav id="site-navigation" class="main-navigation" role="navigation">
					<div class="menu-my-nav-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div><div class="social-menu-container"><ul id="social-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div>					</nav><!-- #site-navigation -->
					
<div id="tetriary" class="left-widget-area" role="complementary">
	<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><hr/></div></aside></div><!-- #tetriary -->
					<div class="site-info">
			<p>© 2020 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>					</div><!-- .site-info -->
				</div>
			</div>
		<div class="left-sidebar-bg">
		</div><!-- .left-sidebar-bg -->
					<div id="footer-widget" class="widget-area" role="complementary">
		<div class="container">
			<div class="row">
		    			</div>
		</div>
	</div><!-- #footer-widget -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
		<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><p>© 2020 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mbu.ug\/2020\/06\/05\/navio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre\/":57639};
	</script>
				<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/photon/photon.min.js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/slick/slick.min.js?ver=20150828'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/theia-sticky-sidebar.min.js?ver=1.2.2'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/ui/effect.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/jquery/ui/effect-slide.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mbu = {"loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","LoginButtonText":"Login","RegisterButtonText":"Create An Account","startPage":"1","maxPages":"0","nextLink":null,"pagination":"infinite","getTemplateDirectoryUri":"https:\/\/mbu.ug\/wp-content\/themes\/mbu","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/mbu.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/skip-link-focus-fix.min.js?ver=20130115'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/comment-reply.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/lazy-images/js/lazy-images.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/postmessage.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/jquery.jetpack-resize.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/likes/queuehandler.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.4.1/wp-includes/js/wp-embed.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/spin.min.js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/jquery.spin.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jetpackCarouselStrings = {"widths":[370,700,1000,1200,1400,2000],"is_logged_in":"","lang":"en","ajaxurl":"https:\/\/mbu.ug\/wp-admin\/admin-ajax.php","nonce":"11c6741dac","display_exif":"1","display_geo":"1","single_image_gallery":"1","single_image_gallery_media_file":"","background_color":"black","comment":"Comment","post_comment":"Post Comment","write_comment":"Write a Comment...","loading_comments":"Loading Comments...","download_original":"View full size <span class=\"photo-size\">{0}<span class=\"photo-size-times\">\u00d7<\/span>{1}<\/span>","no_comment_text":"Please be sure to submit some text with your comment.","no_comment_email":"Please provide an email address to comment.","no_comment_author":"Please provide your name to comment.","comment_post_error":"Sorry, but there was an error posting your comment. Please try again later.","comment_approved":"Your comment was approved.","comment_unapproved":"Your comment is in moderation.","camera":"Camera","aperture":"Aperture","shutter_speed":"Shutter Speed","focal_length":"Focal Length","copyright":"Copyright","comment_registration":"0","require_name_email":"1","login_url":"https:\/\/mbu.ug\/wp-login.php?redirect_to=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F","blog_id":"1","meta_data":["camera","aperture","shutter_speed","focal_length","copyright"],"local_comments_commenting_as":"<fieldset><label for=\"email\">Email (Required)<\/label> <input type=\"text\" name=\"email\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-email-field\" \/><\/fieldset><fieldset><label for=\"author\">Name (Required)<\/label> <input type=\"text\" name=\"author\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-author-field\" \/><\/fieldset><fieldset><label for=\"url\">Website<\/label> <input type=\"text\" name=\"url\" class=\"jp-carousel-comment-form-field jp-carousel-comment-form-text-field\" id=\"jp-carousel-comment-form-url-field\" \/><\/fieldset>"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/carousel/jetpack-carousel.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/8.5/_inc/build/sharedaddy/sharing.min.js'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202023#ver=202023' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=57639&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=49de95771d7f8d92ffea49ce3f05fe760b781cf6#parent=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=57639&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=8.5&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=49de95771d7f8d92ffea49ce3f05fe760b781cf6#parent=https%3A%2F%2Fmbu.ug%2F2020%2F06%2F05%2Fnavio-drops-bangi-visuals-featuring-flex-dpaper-and-daddy-andre%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202023.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.5',blog:'140035613',post:'57639',tz:'3',srv:'mbu.ug'} ]);
	_stq.push([ 'clickTrackerInit', '140035613', '57639' ]);
</script>

</body>
</html>
