<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<link rel="pingback" href="https://mbu.ug/xmlrpc.php">
<!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-110865138-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics -->

	<!-- This site is optimized with the Yoast SEO plugin v15.1.1 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Pastor Augustine Yiga breathes his last, ABS TV confirms</title>
	<meta name="description" content="A few minutes past midnight on Tuesday, ABS Television confirmed through social media that Pastor Augustine Yiga had breathed his last." />
	<meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Pastor Augustine Yiga breathes his last, ABS TV confirms" />
	<meta property="og:description" content="A few minutes past midnight on Tuesday, ABS Television confirmed through social media that Pastor Augustine Yiga had breathed his last." />
	<meta property="og:url" content="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/" />
	<meta property="og:site_name" content="MBU" />
	<meta property="article:publisher" content="https://www.facebook.com/mbu.ug" />
	<meta property="article:author" content="https://www.facebook.com/josh.ruby" />
	<meta property="article:published_time" content="2020-10-26T22:36:10+00:00" />
	<meta property="article:modified_time" content="2020-10-26T22:49:21+00:00" />
	<meta property="og:image" content="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&#038;ssl=1" />
	<meta property="og:image:width" content="554" />
	<meta property="og:image:height" content="554" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:creator" content="@iamjoshruby" />
	<meta name="twitter:site" content="@MBU" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mbu.ug/#organization","name":"Mbu","url":"https://mbu.ug/","sameAs":["https://www.facebook.com/mbu.ug","https://www.instagram.com/mbu.ug/","https://www.youtube.com/channel/UCPNY4Tb3k9PJGfr-zzzfPFg","https://twitter.com/MBU"],"logo":{"@type":"ImageObject","@id":"https://mbu.ug/#logo","inLanguage":"en-US","url":"https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&ssl=1","width":2481,"height":1084,"caption":"Mbu"},"image":{"@id":"https://mbu.ug/#logo"}},{"@type":"WebSite","@id":"https://mbu.ug/#website","url":"https://mbu.ug/","name":"MBU","description":"Uganda&#039;s seriously fun stuff!","publisher":{"@id":"https://mbu.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://mbu.ug/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#primaryimage","inLanguage":"en-US","url":"https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&ssl=1","width":554,"height":554},{"@type":"WebPage","@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#webpage","url":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/","name":"Pastor Augustine Yiga breathes his last, ABS TV confirms","isPartOf":{"@id":"https://mbu.ug/#website"},"primaryImageOfPage":{"@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#primaryimage"},"datePublished":"2020-10-26T22:36:10+00:00","dateModified":"2020-10-26T22:49:21+00:00","description":"A few minutes past midnight on Tuesday, ABS Television confirmed through social media that Pastor Augustine Yiga had breathed his last.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/"]}]},{"@type":"Article","@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#article","isPartOf":{"@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#webpage"},"author":{"@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a"},"headline":"Pastor Augustine Yiga breathes his last, ABS TV confirms","datePublished":"2020-10-26T22:36:10+00:00","dateModified":"2020-10-26T22:49:21+00:00","mainEntityOfPage":{"@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#webpage"},"commentCount":0,"publisher":{"@id":"https://mbu.ug/#organization"},"image":{"@id":"https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#primaryimage"},"keywords":"ABS TV,Pastor Augustine Yiga,Pastor Yiga","articleSection":"News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#respond"]}]},{"@type":"Person","@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a","name":"Josh Ruby","image":{"@type":"ImageObject","@id":"https://mbu.ug/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&d=mm&r=g","caption":"Josh Ruby"},"description":"Simple, Patient, Articulate; but all with a limit. I love writing, reading, interacting with anyone with leads in Ugandan entertainment news.","sameAs":["http://www.mbu.ug","https://www.facebook.com/josh.ruby","https://www.instagram.com/iamjoshruby/","https://twitter.com/iamjoshruby","https://www.youtube.com/channel/UCMZgCJ0KrQb7JBKobh2OjvQ","https://www.tumblr.com/blog/joshruby"]}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//www.googletagmanager.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//widgets.wp.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Feed" href="https://mbu.ug/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Comments Feed" href="https://mbu.ug/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="MBU &raquo; Pastor Augustine Yiga breathes his last, ABS TV confirms Comments Feed" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mbu.ug\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.1"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link crossorigin="anonymous" rel='stylesheet' id='mbu-fonts-css'  href='https://fonts.googleapis.com/css?family=Amiri%3A700%2C400%2C400italic%7CWork+Sans%3A400&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='mbu-style-css'  href='https://mbu.ug/wp-content/themes/mbu/style.css?ver=1.0' type='text/css' media='all' />
<style id='mbu-style-inline-css' type='text/css'>
.site-title, .site-description {display:none;}
		.site-branding {padding:0;}.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:300px;}
		#secondary .widget:nth-of-type(3n+1), #secondary .widget:nth-of-type(3n+1) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+2), #secondary .widget:nth-of-type(3n+2) .widget-title span {background-color:#f8f8f8;}
		#secondary .widget:nth-of-type(3n+3), #secondary .widget:nth-of-type(3n+3) .widget-title span {background-color:#f8f8f8;}
		#footer-widget, #footer-widget .widget-title span {background-color:#f8f8f8}.woocommerce .page-title {display:none;}@media screen and (min-width:978px )  {
		.menu-logo {float:left;}
		.navbar-navigation ul, .nav-social {display:block;}
		.mbu-featured-slider, .mbu-featured-slider .featured-image, .mbu-featured-slider .no-featured-image {height:500px;}
		}
</style>
<link rel='stylesheet' id='social-logos-css'  href='https://c0.wp.com/p/jetpack/9.0.2/_inc/social-logos/social-logos.min.css' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script>
<script type='text/javascript' id='jetpack_related-posts-js-extra'>
/* <![CDATA[ */
var related_posts_js_options = {"post_heading":"h4"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script>
<script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-110865138-1' id='google_gtagjs-js' async></script>
<script type='text/javascript' id='google_gtagjs-js-after'>
window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('set', 'linker', {"domains":["mbu.ug"]} );
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-110865138-1', {"anonymize_ip":true} );
</script>
<link rel="https://api.w.org/" href="https://mbu.ug/wp-json/" /><link rel="alternate" type="application/json" href="https://mbu.ug/wp-json/wp/v2/posts/67974" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mbu.ug/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mbu.ug/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.1" />
<link rel='shortlink' href='https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/' />
<link rel="alternate" type="application/json+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F10%2F27%2Fpastor-augustine-yiga-breathes-his-last-abs-tv-confirms%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F10%2F27%2Fpastor-augustine-yiga-breathes-his-last-abs-tv-confirms%2F&#038;format=xml" />
<meta name="generator" content="Site Kit by Google 1.18.0" />		<link rel="manifest" href="https://mbu.ug/wp-json/wp/v2/web-app-manifest">
		<meta name="theme-color" content="#fff">
		<meta name="apple-mobile-web-app-capable" content="yes">
		<meta name="mobile-web-app-capable" content="yes">
		<meta name="apple-touch-fullscreen" content="YES">
							<link rel="apple-touch-startup-image" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&#038;ssl=1">
		
				<meta name="apple-mobile-web-app-title" content="MBU">
		<meta name="application-name" content="MBU">
		<style type='text/css'>img#wpstats{display:none}</style>			<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="amphtml" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/amp/"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-0521644691090227","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=270%2C270&#038;ssl=1" />
</head>

<body class="post-template-default single single-post postid-67974 single-format-standard wp-custom-logo group-blog">
<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header" role="banner">
				<nav id="top-navigation" class="navbar-navigation" role="navigation">

					<button id="left-navbar-toggle" class="menu-toggle" aria-controls="left-sidebar" aria-expanded="false"><span class="screen-reader-text">Menu</span><svg><path d="M3 6h18v2.016h-18v-2.016zM3 12.984v-1.969h18v1.969h-18zM3 18v-2.016h18v2.016h-18z"></path></svg></button>
										<button id="navbar-search-toggle" class="search-toggle" aria-controls="search-panel" aria-expanded="false"><span class="screen-reader-text">Search</span><svg><path d="M9.516 14.016q1.875 0 3.188-1.313t1.313-3.188-1.313-3.188-3.188-1.313-3.188 1.313-1.313 3.188 1.313 3.188 3.188 1.313zM15.516 14.016l4.969 4.969-1.5 1.5-4.969-4.969v-0.797l-0.281-0.281q-1.781 1.547-4.219 1.547-2.719 0-4.617-1.875t-1.898-4.594 1.898-4.617 4.617-1.898 4.594 1.898 1.875 4.617q0 2.438-1.547 4.219l0.281 0.281h0.797z"></path></svg></button>
					<div id="search-panel" class="mbu-search-panel">
					    <button class="mbu-search-panel-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
						<form role="search" method="get" class="search-form" action="https://mbu.ug/">
	<label>
			<span class="screen-reader-text">Search for: </span>
			<input type="search" class="search-field" placeholder="Type and hit enter" value="" name="s" title="Search for:" />
	</label>
	<input type="submit" class="search-submit" value="Search" />
</form>   
	
					</div>

					<div class="menu-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					</div>
						<div class="social-menu-container"><ul id="social-menu" class="menu"><li id="menu-item-4692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li id="menu-item-4693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div><div class="menu-my-nav-container"><ul id="top-menu" class="menu"><li id="menu-item-1944" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li id="menu-item-1933" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li id="menu-item-1932" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li id="menu-item-1941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li id="menu-item-2299" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li id="menu-item-2300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li id="menu-item-46421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div>		</nav><!-- #site-navigation -->

	    
	</header><!-- #masthead -->

	
	<div id="content" class="site-content container">
	<div id="top-widget" class="widget-area row" role="complementary">
	    <aside id="custom_html-7" class="widget_text widget widget_custom_html col-xs-12"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- mbu_leaderboard -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="5419942286"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>	</div><!-- #top-widget -->
<div class="row">
		<div id="primary" class="content-area col-lg-8">
		<main id="main" class="site-main row" role="main">

		
			
<article id="post-67974" class="col-xs-12 post-67974 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-abs-tv tag-pastor-augustine-yiga tag-pastor-yiga">


						<div class="category-list">
						<a href="https://mbu.ug/news/">News</a>						</div>

	<header class="entry-header row">

		<h1 class="entry-title col-xs-12">Pastor Augustine Yiga breathes his last, ABS TV confirms</h1>		<div class="entry-meta  col-xs-12">
			<span class="byline"> <span class="author vcard"><img alt src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&#038;d=mm&#038;r=g" class="avatar avatar-96 photo jetpack-lazy-image" height="96" width="96" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=192&#038;d=mm&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&amp;is-pending-load=1#038;d=mm&#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=192&#038;d=mm&#038;r=g 2x' class='avatar avatar-96 photo' height='96' width='96' loading='lazy'/></noscript><a class="url fn n" href="https://mbu.ug/author/joshualubanga/">Josh Ruby</a></span></span><div class="mbu-posted-on-sharing-wrapper"><span class="posted-on"><a href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/" rel="bookmark"><time class="entry-date published updated" datetime="2020-10-27T01:36:10+03:00">5 hours</time></a> ago</span><div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-67974" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-67974" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-67974" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div></div>		</div><!-- .entry-meta -->

	</header><!-- .entry-header -->
			<div class="row">
			<div class="single-featured-image col-xs-12"   >
				<img width="554" height="554" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1" class="attachment-full size-full wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="55613" data-permalink="https://mbu.ug/2020/05/05/pastor-augustine-yiga-granted-shs2m-non-cash-bail/yiga-2-2/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1" data-orig-size="554,554" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Pastor Yiga" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=448%2C448&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?w=554&amp;ssl=1 554w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=448%2C448&amp;ssl=1 448w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=80%2C80&amp;ssl=1 80w" data-lazy-sizes="(max-width: 554px) 100vw, 554px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			</div>
		</div>
		<div class="row">

	<div class="entry-content col-xs-12">
		
<p class="has-drop-cap">In a statement released across ABS Television&#8217;s social media pages, it was confirmed on Tuesday 27th October 2020 that Pastor Augustine Yiga a.k.a Abizaayo had breathed his last.</p>



<p>On 23rd October, several reports had it that the Kawaala-based Revival Church pastor Augustine Yiga had breathed his last. His family, however, rubbished the reports labeling them false.</p>



<p>At just a few minutes past midnight on Tuesday, ABS Television Facebook page confirmed in an announcement that the comic pastor had breathed his last.</p><aside class="scaip scaip-1    "><aside id="custom_html-8" class="widget_text widget_custom_html clearfix"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="5084224115"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside></aside>



<figure class="wp-block-embed-instagram wp-block-embed"><div class="wp-block-embed__wrapper">
<blockquote class="instagram-media" data-instgrm-captioned data-instgrm-permalink="https://www.instagram.com/p/CG0oq8eFV0z/?utm_source=ig_embed&amp;utm_campaign=loading" data-instgrm-version="12" style=" background:#FFF; border:0; border-radius:3px; box-shadow:0 0 1px 0 rgba(0,0,0,0.5),0 1px 10px 0 rgba(0,0,0,0.15); margin: 1px; max-width:658px; min-width:326px; padding:0; width:99.375%; width:-webkit-calc(100% - 2px); width:calc(100% - 2px);"><div style="padding:16px;"> <a href="https://www.instagram.com/p/CG0oq8eFV0z/?utm_source=ig_embed&amp;utm_campaign=loading" style=" background:#FFFFFF; line-height:0; padding:0 0; text-align:center; text-decoration:none; width:100%;" target="_blank"> <div style=" display: flex; flex-direction: row; align-items: center;"> <div style="background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 40px; margin-right: 14px; width: 40px;"></div> <div style="display: flex; flex-direction: column; flex-grow: 1; justify-content: center;"> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; margin-bottom: 6px; width: 100px;"></div> <div style=" background-color: #F4F4F4; border-radius: 4px; flex-grow: 0; height: 14px; width: 60px;"></div></div></div><div style="padding: 19% 0;"></div> <div style="display:block; height:50px; margin:0 auto 12px; width:50px;"><svg width="50px" height="50px" viewBox="0 0 60 60" version="1.1" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-511.000000, -20.000000)" fill="#000000"><g><path d="M556.869,30.41 C554.814,30.41 553.148,32.076 553.148,34.131 C553.148,36.186 554.814,37.852 556.869,37.852 C558.924,37.852 560.59,36.186 560.59,34.131 C560.59,32.076 558.924,30.41 556.869,30.41 M541,60.657 C535.114,60.657 530.342,55.887 530.342,50 C530.342,44.114 535.114,39.342 541,39.342 C546.887,39.342 551.658,44.114 551.658,50 C551.658,55.887 546.887,60.657 541,60.657 M541,33.886 C532.1,33.886 524.886,41.1 524.886,50 C524.886,58.899 532.1,66.113 541,66.113 C549.9,66.113 557.115,58.899 557.115,50 C557.115,41.1 549.9,33.886 541,33.886 M565.378,62.101 C565.244,65.022 564.756,66.606 564.346,67.663 C563.803,69.06 563.154,70.057 562.106,71.106 C561.058,72.155 560.06,72.803 558.662,73.347 C557.607,73.757 556.021,74.244 553.102,74.378 C549.944,74.521 548.997,74.552 541,74.552 C533.003,74.552 532.056,74.521 528.898,74.378 C525.979,74.244 524.393,73.757 523.338,73.347 C521.94,72.803 520.942,72.155 519.894,71.106 C518.846,70.057 518.197,69.06 517.654,67.663 C517.244,66.606 516.755,65.022 516.623,62.101 C516.479,58.943 516.448,57.996 516.448,50 C516.448,42.003 516.479,41.056 516.623,37.899 C516.755,34.978 517.244,33.391 517.654,32.338 C518.197,30.938 518.846,29.942 519.894,28.894 C520.942,27.846 521.94,27.196 523.338,26.654 C524.393,26.244 525.979,25.756 528.898,25.623 C532.057,25.479 533.004,25.448 541,25.448 C548.997,25.448 549.943,25.479 553.102,25.623 C556.021,25.756 557.607,26.244 558.662,26.654 C560.06,27.196 561.058,27.846 562.106,28.894 C563.154,29.942 563.803,30.938 564.346,32.338 C564.756,33.391 565.244,34.978 565.378,37.899 C565.522,41.056 565.552,42.003 565.552,50 C565.552,57.996 565.522,58.943 565.378,62.101 M570.82,37.631 C570.674,34.438 570.167,32.258 569.425,30.349 C568.659,28.377 567.633,26.702 565.965,25.035 C564.297,23.368 562.623,22.342 560.652,21.575 C558.743,20.834 556.562,20.326 553.369,20.18 C550.169,20.033 549.148,20 541,20 C532.853,20 531.831,20.033 528.631,20.18 C525.438,20.326 523.257,20.834 521.349,21.575 C519.376,22.342 517.703,23.368 516.035,25.035 C514.368,26.702 513.342,28.377 512.574,30.349 C511.834,32.258 511.326,34.438 511.181,37.631 C511.035,40.831 511,41.851 511,50 C511,58.147 511.035,59.17 511.181,62.369 C511.326,65.562 511.834,67.743 512.574,69.651 C513.342,71.625 514.368,73.296 516.035,74.965 C517.703,76.634 519.376,77.658 521.349,78.425 C523.257,79.167 525.438,79.673 528.631,79.82 C531.831,79.965 532.853,80.001 541,80.001 C549.148,80.001 550.169,79.965 553.369,79.82 C556.562,79.673 558.743,79.167 560.652,78.425 C562.623,77.658 564.297,76.634 565.965,74.965 C567.633,73.296 568.659,71.625 569.425,69.651 C570.167,67.743 570.674,65.562 570.82,62.369 C570.966,59.17 571,58.147 571,50 C571,41.851 570.966,40.831 570.82,37.631"></path></g></g></g></svg></div><div style="padding-top: 8px;"> <div style=" color:#3897f0; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:550; line-height:18px;"> View this post on Instagram</div></div><div style="padding: 12.5% 0;"></div> <div style="display: flex; flex-direction: row; margin-bottom: 14px; align-items: center;"><div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(0px) translateY(7px);"></div> <div style="background-color: #F4F4F4; height: 12.5px; transform: rotate(-45deg) translateX(3px) translateY(1px); width: 12.5px; flex-grow: 0; margin-right: 14px; margin-left: 2px;"></div> <div style="background-color: #F4F4F4; border-radius: 50%; height: 12.5px; width: 12.5px; transform: translateX(9px) translateY(-18px);"></div></div><div style="margin-left: 8px;"> <div style=" background-color: #F4F4F4; border-radius: 50%; flex-grow: 0; height: 20px; width: 20px;"></div> <div style=" width: 0; height: 0; border-top: 2px solid transparent; border-left: 6px solid #f4f4f4; border-bottom: 2px solid transparent; transform: translateX(16px) translateY(-4px) rotate(30deg)"></div></div><div style="margin-left: auto;"> <div style=" width: 0px; border-top: 8px solid #F4F4F4; border-right: 8px solid transparent; transform: translateY(16px);"></div> <div style=" background-color: #F4F4F4; flex-grow: 0; height: 12px; width: 16px; transform: translateY(-4px);"></div> <div style=" width: 0; height: 0; border-top: 8px solid #F4F4F4; border-left: 8px solid transparent; transform: translateY(-4px) translateX(8px);"></div></div></div></a> <p style=" margin:8px 0 0 0; padding:0 4px;"> <a href="https://www.instagram.com/p/CG0oq8eFV0z/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#000; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px; text-decoration:none; word-wrap:break-word;" target="_blank">#RIP #PASTOR YIGA #KIKI KYOLIFA TEWELABIDE #BLOOD WANGE</a></p> <p style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; line-height:17px; margin-bottom:0; margin-top:8px; overflow:hidden; padding:8px 0 7px; text-align:center; text-overflow:ellipsis; white-space:nowrap;">A post shared by <a href="https://www.instagram.com/kabako_makanaki_/?utm_source=ig_embed&amp;utm_campaign=loading" style=" color:#c9c8cd; font-family:Arial,sans-serif; font-size:14px; font-style:normal; font-weight:normal; line-height:17px;" target="_blank"> Ssenabulya Yusuf Roden</a> (@kabako_makanaki_) on <time style=" font-family:Arial,sans-serif; font-size:14px; line-height:17px;" datetime="2020-10-26T21:49:44+00:00">Oct 26, 2020 at 2:49pm PDT</time></p></div></blockquote>
</div></figure>



<p>&#8220;There are no goodbyes. Wherever you&#8217;ll be, you&#8217;ll be in our hearts.<br>You will always be within us, it&#8217;s just the graveyard where you lay to rest. We cannot believe that you are no longer with us. This is a tragedy for us, we will pray for you dear friend, father, mentor, great pastor. Rest in peace. Pastor yiga abizaayo Augustine,&#8221; read a statement on ABS TV Facebook page.</p><aside class="scaip scaip-2    "><aside id="custom_html-6" class="widget_text widget_custom_html clearfix"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-0521644691090227"
     data-ad-slot="5084224115"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside></aside>



<amp-fit-text layout="fixed-height" min-font-size="6" max-font-size="72" height="80"><p></p></amp-fit-text><iframe src="https://www.facebook.com/plugins/post.php?href=https%3A%2F%2Fwww.facebook.com%2Fabstvugandaofficialpage%2Fposts%2F1725602834260097&#038;width=500" width="500" height="497" style="border:none;overflow:hidden" scrolling="no" frameborder="0" allowTransparency="true" allow="encrypted-media"></iframe>



<p>In recent weeks, we have been reporting about how the jolly and comic pastor was <a href="https://mbu.ug/2020/10/14/pastor-yiga-reportedly-seriously-ill-admitted-at-nsambya-hospital/" target="_blank" rel="noreferrer noopener"><span class="has-inline-color has-vivid-red-color">bedridden at Nsambya Hospital</span></a> with what was referred to as “Liver complications”.</p>



<p>The cause of his eventual death has not yet been established but we shall keep you updated. May his soul Rest In Peace!</p>



<p class="has-text-align-center"><strong>Read Also: </strong><a href="https://mbu.ug/2020/10/25/abs-tv-is-not-for-sale-pastor-yigas-son-andrew-jjengo-maintains/" target="_blank" rel="noreferrer noopener"><span class="has-inline-color has-vivid-cyan-blue-color">ABS TV is not for sale – Pastor Yiga’s son Andrew Jjengo maintains</span></a></p>
<div class='sharedaddy sd-block sd-like jetpack-likes-widget-wrapper jetpack-likes-widget-unloaded' id='like-post-wrapper-140035613-67974-5f978f17766bd' data-src='https://widgets.wp.com/likes/#blog_id=140035613&amp;post_id=67974&amp;origin=mbu.ug&amp;obj_id=140035613-67974-5f978f17766bd' data-name='like-post-frame-140035613-67974-5f978f17766bd'><h3 class="sd-title">Like this:</h3><div class='likes-widget-placeholder post-likes-widget-placeholder' style='height: 55px;'><span class='button'><span>Like</span></span> <span class="loading">Loading...</span></div><span class='sd-text-color'></span><a class='sd-link-color'></a></div>
<div id='jp-relatedposts' class='jp-relatedposts' >
	
</div>			</div><!-- .entry-content -->

	<footer class="entry-footer col-xs-12">
		<div class="mbu-jp-sharing"><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-67974" class="share-facebook sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-67974" class="share-twitter sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-jetpack-whatsapp"><a rel="nofollow noopener noreferrer" data-shared="" class="share-jetpack-whatsapp sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=jetpack-whatsapp" target="_blank" title="Click to share on WhatsApp"><span></span><span class="sharing-screen-reader-text">Click to share on WhatsApp (Opens in new window)</span></a></li><li class="share-tumblr"><a rel="nofollow noopener noreferrer" data-shared="" class="share-tumblr sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=tumblr" target="_blank" title="Click to share on Tumblr"><span></span><span class="sharing-screen-reader-text">Click to share on Tumblr (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-67974" class="share-linkedin sd-button share-icon no-text" href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div></div><span class="tags-links">Tagged: <a href="https://mbu.ug/tag/abs-tv/" rel="tag">ABS TV</a>, <a href="https://mbu.ug/tag/pastor-augustine-yiga/" rel="tag">Pastor Augustine Yiga</a>, <a href="https://mbu.ug/tag/pastor-yiga/" rel="tag">Pastor Yiga</a></span>	</footer><!-- .entry-footer -->

	</div><!-- .row -->

</article><!-- #post-## -->

								<div class="mbu-related-posts col-xs-12">
						<h3><span>You May Also Like</span></h3>
						<div class="row">
											<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/10/26/eddy-kenzo-wins-big-at-hollywood-awards/" title="Eddy Kenzo wins big at Hollywood awards" style="background: url( https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/122208646_1747432478747801_1978653926230508067_o-edited.jpg?fit=448%2C280&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/10/26/eddy-kenzo-wins-big-at-hollywood-awards/" title="Eddy Kenzo wins big at Hollywood awards">Eddy Kenzo wins big at Hollywood awards</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/10/26/beenie-gunter-confirms-welcoming-bundle-of-joy-reveals-his-name/" title="Beenie Gunter confirms welcoming bundle of joy, reveals his name" style="background: url( https://i2.wp.com/mbu.ug/wp-content/uploads/2020/10/beeniegunter_20201026_082752-edited.jpg?fit=448%2C280&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/10/26/beenie-gunter-confirms-welcoming-bundle-of-joy-reveals-his-name/" title="Beenie Gunter confirms welcoming bundle of joy, reveals his name">Beenie Gunter confirms welcoming bundle of joy, reveals his name</a></h4>
					</div>
									<div class="col-xs-12 col-md-4">
													<a class="related-posts-thumbnail" href="https://mbu.ug/2020/10/25/b2c-entertainment-send-out-message-of-african-solidarity-during-club-beatz-show/" title="B2C Entertainment send out message of African Solidarity during Club Beatz show" style="background: url( https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/IMG-20201024-WA0031.jpg?fit=448%2C299&#038;ssl=1 ) center no-repeat;background-size: cover;"></a>
										 		<h4><a href="https://mbu.ug/2020/10/25/b2c-entertainment-send-out-message-of-african-solidarity-during-club-beatz-show/" title="B2C Entertainment send out message of African Solidarity during Club Beatz show">B2C Entertainment send out message of African Solidarity during Club Beatz show</a></h4>
					</div>
										</div>
					</div>
				
			
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://mbu.ug/2020/10/26/maureen-nantume-breaks-down-after-sharing-emotional-life-story/" rel="prev"><div class="mbu-previous-article">Previous article</div><div class="mbu-previous-article-title">Maureen Nantume breaks down after sharing emotional life story</div></a></div></div>
	</nav>
			
<div id="comments" class="comments-area col-md-12">

	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&#038;postid=67974&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=1&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=mystery&#038;greeting=&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.0.2&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=f4177dd653e73c4fe7175633d62cbb9006e5c679#parent=https%3A%2F%2Fmbu.ug%2F2020%2F10%2F27%2Fpastor-augustine-yiga-breathes-his-last-abs-tv-confirms%2F" style="width:100%; height: 430px; border:0;" name="jetpack_remote_comment" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"></iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-lg-4" role="complementary">
	<div class="theiaStickySidebar">
	<aside id="facebook_likebox_by_fat-2" class="widget widget_facebook_likebox">		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/mbu.ug" data-width="350"  data-height="300" data-hide-cover="false" data-show-facepile="false" data-show-posts="true">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/mbu.ug"><a href="https://www.facebook.com/mbu.ug"></a></blockquote></div>
		</div>
		<script>(function(d, s, id) { var js, fjs = d.getElementsByTagName(s)[0]; if (d.getElementById(id)) return; js = d.createElement(s); js.id = id; js.src = '//connect.facebook.net/en_US/sdk.js#xfbml=1&appId=249643311490&version=v2.3'; fjs.parentNode.insertBefore(js, fjs); }(document, 'script', 'facebook-jssdk'));</script>
		</aside><aside id="text-4" class="widget widget_text">			<div class="textwidget"><p><a class="twitter-timeline" data-height="300" href="https://twitter.com/MBU?ref_src=twsrc%5Etfw">Tweets by MBU</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></p>
</div>
		</aside>		<aside id="fat-recent-posts-3" class="widget fat_widget_recent_entries">		<h2 class="widget-title"><span>Recent Posts</span></h2>		<ul>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="55613" data-permalink="https://mbu.ug/2020/05/05/pastor-augustine-yiga-granted-shs2m-non-cash-bail/yiga-2-2/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1" data-orig-size="554,554" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Pastor Yiga" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=448%2C448&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?fit=554%2C554&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?w=554&amp;ssl=1 554w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=448%2C448&amp;ssl=1 448w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=80%2C80&amp;ssl=1 80w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/05/Yiga-2.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/10/27/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms/">Pastor Augustine Yiga breathes his last, ABS TV confirms</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/10/26/maureen-nantume-breaks-down-after-sharing-emotional-life-story/"><img width="80" height="80" src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="67956" data-permalink="https://mbu.ug/2020/10/26/maureen-nantume-breaks-down-after-sharing-emotional-life-story/bugembe-nantume/" data-orig-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?fit=1080%2C720&amp;ssl=1" data-orig-size="1080,720" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="Bugembe &#8211; Nantume" data-image-description="" data-medium-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?fit=448%2C299&amp;ssl=1" data-large-file="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?fit=738%2C492&amp;ssl=1" data-lazy-srcset="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?resize=80%2C80&amp;ssl=1 80w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i1.wp.com/mbu.ug/wp-content/uploads/2020/10/Bugembe-Nantume.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/10/26/maureen-nantume-breaks-down-after-sharing-emotional-life-story/">Maureen Nantume breaks down after sharing emotional life story</a></h3>
	      				      </div>
			</li>
					<li class="recent-post-list-item">
							    <a href="https://mbu.ug/2020/10/26/jk-dave-kazoora-shares-how-he-was-bounced-thrice-at-campus/"><img width="80" height="80" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?resize=80%2C80&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-attachment-id="56883" data-permalink="https://mbu.ug/2020/05/25/dont-bring-her-back-fans-warn-jk-kazoora-on-alicia-bosschic/jk-kazoora-2/" data-orig-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?fit=1080%2C719&amp;ssl=1" data-orig-size="1080,719" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="JK Kazoora (2)" data-image-description="" data-medium-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?fit=448%2C298&amp;ssl=1" data-large-file="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?fit=738%2C491&amp;ssl=1" data-lazy-srcset="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?resize=80%2C80&amp;ssl=1 80w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?zoom=2&amp;resize=80%2C80&amp;ssl=1 160w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?zoom=3&amp;resize=80%2C80&amp;ssl=1 240w" data-lazy-sizes="(max-width: 80px) 100vw, 80px" data-lazy-src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/05/JK-Kazoora-2.jpg?resize=80%2C80&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>
							  <div>
				<h3 class="recent-post-title"><a href="https://mbu.ug/2020/10/26/jk-dave-kazoora-shares-how-he-was-bounced-thrice-at-campus/">JK Dave Kazoora shares how he was bounced thrice at campus</a></h3>
	      				      </div>
			</li>
				</ul>
		</aside>		<aside id="fat_widget_instagram-3" class="widget fat__widget-instagram"><h3 class="screen-reader-text">Instagram</h3><div class="fat__instagram-container"><span class="error">Nothing to show.</span></div></aside>	</div>
</div><!-- #secondary -->
</div><!-- .row -->

	</div><!-- #content -->

			<div id="left-sidebar" class="left-sidebar-area">
				<div class="left-sidebar-content">
					<div class="left-header">
					<div class="left-logo">
						<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a>					<button class="left-sidebar-close" title="Close"><svg><path d="M18.984 6.422l-5.578 5.578 5.578 5.578-1.406 1.406-5.578-5.578-5.578 5.578-1.406-1.406 5.578-5.578-5.578-5.578 1.406-1.406 5.578 5.578 5.578-5.578z"></path></svg></button>
					</div>
					</div>
					<nav id="site-navigation" class="main-navigation" role="navigation">
					<div class="menu-my-nav-container"><ul id="primary-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-1944"><a href="https://mbu.ug">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1933"><a href="https://mbu.ug/news/">News</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1932"><a href="https://mbu.ug/music/">Music</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1941"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2299"><a href="https://mbu.ug/gossip/">Gossip</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2300"><a href="https://mbu.ug/film/">Film</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-46421"><a href="https://mbu.ug/lifestyle/fashion/">Fashion</a></li>
</ul></div><div class="social-menu-container"><ul id="social-menu" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a href="https://facebook.com"><span class="screen-reader-text">facebook</span></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a href="https://twitter.com"><span class="screen-reader-text">twitter</span></a></li>
</ul></div>					</nav><!-- #site-navigation -->
					
<div id="tetriary" class="left-widget-area" role="complementary">
	<aside id="custom_html-5" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><hr/></div></aside></div><!-- #tetriary -->
					<div class="site-info">
			<p>© 2020 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>					</div><!-- .site-info -->
				</div>
			</div>
		<div class="left-sidebar-bg">
		</div><!-- .left-sidebar-bg -->
					<div id="footer-widget" class="widget-area" role="complementary">
		<div class="container">
			<div class="row">
		    			</div>
		</div>
	</div><!-- #footer-widget -->
		<footer id="colophon" class="site-footer" role="contentinfo">
		<div class="site-info">
		<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><img width="2481" height="1084" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo jetpack-lazy-image" alt="MBU" data-attachment-id="50490" data-permalink="https://mbu.ug/mbu-logo1-01/" data-orig-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1" data-orig-size="2481,1084" data-comments-opened="1" data-image-meta="{&quot;aperture&quot;:&quot;0&quot;,&quot;credit&quot;:&quot;&quot;,&quot;camera&quot;:&quot;&quot;,&quot;caption&quot;:&quot;&quot;,&quot;created_timestamp&quot;:&quot;0&quot;,&quot;copyright&quot;:&quot;&quot;,&quot;focal_length&quot;:&quot;0&quot;,&quot;iso&quot;:&quot;0&quot;,&quot;shutter_speed&quot;:&quot;0&quot;,&quot;title&quot;:&quot;&quot;,&quot;orientation&quot;:&quot;0&quot;}" data-image-title="mbu logo1-01" data-image-description="" data-medium-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=448%2C196&amp;ssl=1" data-large-file="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=738%2C322&amp;ssl=1" data-lazy-srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2481&amp;ssl=1 2481w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=448%2C196&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=738%2C322&amp;ssl=1 738w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=768%2C336&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=1536%2C671&amp;ssl=1 1536w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?resize=2048%2C895&amp;ssl=1 2048w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=1476&amp;ssl=1 1476w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?w=2214&amp;ssl=1 2214w" data-lazy-sizes="(max-width: 2481px) 100vw, 2481px" data-lazy-src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" /></a><p>© 2020 MBU. All Rights reserved.</p>
<p>MBU is a division of OWINO SOLUTIONS. Content may not be reproduced or published in any form without authorisation.</p>		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->


	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mbu.ug\/2020\/10\/27\/pastor-augustine-yiga-breathes-his-last-abs-tv-confirms\/":67974};
	</script>
					<script>
		if ( navigator.serviceWorker ) {
			window.addEventListener( 'load', function() {
									{
						navigator.serviceWorker.register(
							"\/?wp_service_worker=1",
							{"scope":"\/"}						).then( reg => {
													} );
					}
							} );
		}
	</script>
	<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/slick/slick.min.js?ver=20150828' id='slick-js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/theia-sticky-sidebar.min.js?ver=1.2.2' id='theia-sticky-sidebar-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/ui/effect.min.js' id='jquery-effects-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/jquery/ui/effect-slide.min.js' id='jquery-effects-slide-js'></script>
<script type='text/javascript' id='mbu-scripts-js-extra'>
/* <![CDATA[ */
var mbu = {"loadMoreText":"Load more posts","loadingText":" ","noMorePostsText":"No More Posts","expandText":"Expand","closeText":"Close","LoginButtonText":"Login","RegisterButtonText":"Create An Account","startPage":"1","maxPages":"0","nextLink":"","pagination":"infinite","getTemplateDirectoryUri":"https:\/\/mbu.ug\/wp-content\/themes\/mbu","months":["January","February","March","April","May","June","July","August","September","October","November","December"],"days":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/mbu.min.js?ver=1.0' id='mbu-scripts-js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/themes/mbu/js/skip-link-focus-fix.min.js?ver=20130115' id='mbu-skip-link-focus-fix-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://mbu.ug/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.0.0' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/postmessage.min.js' id='postmessage-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/jquery.jetpack-resize.min.js' id='jetpack_resize-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/likes/queuehandler.min.js' id='jetpack_likes_queuehandler-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.5.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/shortcodes/js/instagram.min.js' id='jetpack-instagram-embed-js'></script>
<script type='text/javascript' id='sharing-js-js-extra'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/sharedaddy/sharing.min.js' id='sharing-js-js'></script>
<script type='text/javascript' id='sharing-js-js-after'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-tumblr', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtumblr', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
</script>
	<iframe src='https://widgets.wp.com/likes/master.html?ver=202044#ver=202044' scrolling='no' id='likes-master' name='likes-master' style='display:none;'></iframe>
	<div id='likes-other-gravatars'><div class="likes-text"><span>%d</span> bloggers like this:</div><ul class="wpl-avatars sd-like-gravatars"></ul></div>
	
		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=67974&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f4177dd653e73c4fe7175633d62cbb9006e5c679#parent=https%3A%2F%2Fmbu.ug%2F2020%2F10%2F27%2Fpastor-augustine-yiga-breathes-his-last-abs-tv-confirms%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&postid=67974&comment_registration=0&require_name_email=1&stc_enabled=1&stb_enabled=1&show_avatars=1&avatar_default=mystery&greeting=&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.0.2&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=f4177dd653e73c4fe7175633d62cbb9006e5c679#parent=https%3A%2F%2Fmbu.ug%2F2020%2F10%2F27%2Fpastor-augustine-yiga-breathes-his-last-abs-tv-confirms%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script type='text/javascript' src='https://stats.wp.com/e-202044.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'140035613',post:'67974',tz:'3',srv:'mbu.ug'} ]);
	_stq.push([ 'clickTrackerInit', '140035613', '67974' ]);
</script>

</body>
</html>
