<!DOCTYPE html>
<html lang="en-US" amp="" i-amphtml-layout="" i-amphtml-no-boilerplate="" transformed="self;v=1">
<head><meta charset="UTF-8"><style amp-runtime="" i-amphtml-version="012011070101001">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</style><meta name="viewport" content="width=device-width,initial-scale=1"><meta name="description" content="Uganda Musicians Association president Ykee Benda lives to tell the tale after he cheated death following a nasty accident."><meta name="robots" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1"><meta property="og:locale" content="en_US"><meta property="og:type" content="article"><meta property="og:title" content="Ykee Benda and family survive nasty accident (PHOTOS)"><meta property="og:description" content="Uganda Musicians Association president Ykee Benda lives to tell the tale after he cheated death following a nasty accident."><meta property="og:url" content="https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/"><meta property="og:site_name" content="MBU"><meta property="article:publisher" content="https://www.facebook.com/mbu.ug"><meta property="article:author" content="https://www.facebook.com/josh.ruby"><meta property="article:published_time" content="2020-11-23T07:31:49+00:00"><meta property="article:modified_time" content="2020-11-23T07:55:43+00:00"><meta property="og:image" content="https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?fit=1040%2C692&amp;ssl=1"><meta property="og:image:width" content="1040"><meta property="og:image:height" content="692"><meta name="twitter:card" content="summary_large_image"><meta name="twitter:creator" content="@iamjoshruby"><meta name="twitter:site" content="@MBU"><meta name="twitter:label1" content="Written by"><meta name="twitter:data1" content="Josh Ruby"><meta name="twitter:label2" content="Est. reading time"><meta name="twitter:data2" content="1 minute"><meta name="generator" content="WordPress 5.5.3"><meta name="generator" content="Site Kit by Google 1.20.0"><meta name="theme-color" content="#fff"><meta name="apple-mobile-web-app-capable" content="yes"><meta name="mobile-web-app-capable" content="yes"><meta name="apple-touch-fullscreen" content="YES"><meta name="apple-mobile-web-app-title" content="MBU"><meta name="application-name" content="MBU"><meta name="generator" content="AMP Plugin v2.0.5; mode=standard"><meta name="msapplication-TileImage" content="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=270%2C270&amp;ssl=1"><title>Ykee Benda and family survive nasty accident (PHOTOS)</title><link rel="preconnect" href="https://cdn.ampproject.org"><link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin=""><link rel="dns-prefetch" href="//cdn.ampproject.org"><link rel="dns-prefetch" href="//fonts.googleapis.com"><link rel="dns-prefetch" href="//s.w.org"><link rel="dns-prefetch" href="//widgets.wp.com"><link rel="dns-prefetch" href="//s0.wp.com"><link rel="dns-prefetch" href="//0.gravatar.com"><link rel="dns-prefetch" href="//1.gravatar.com"><link rel="dns-prefetch" href="//2.gravatar.com"><link rel="dns-prefetch" href="//i0.wp.com"><link rel="dns-prefetch" href="//i1.wp.com"><link rel="dns-prefetch" href="//i2.wp.com"><link rel="dns-prefetch" href="//jetpack.wordpress.com"><link rel="dns-prefetch" href="//s1.wp.com"><link rel="dns-prefetch" href="//s2.wp.com"><link rel="dns-prefetch" href="//public-api.wordpress.com"><link rel="dns-prefetch" href="//c0.wp.com"><link rel="preload" as="script" href="https://cdn.ampproject.org/v0.js"><script type="text/javascript" src="https://cdn.ampproject.org/v0.js" id="amp-runtime-js" async></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-access-0.1.js" id="amp-access-js" async custom-element="amp-access"></script><script src="https://cdn.ampproject.org/v0/amp-ad-0.1.js" async="" custom-element="amp-ad"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-analytics-0.1.js" id="amp-analytics-js" async custom-element="amp-analytics"></script><script src="https://cdn.ampproject.org/v0/amp-auto-ads-0.1.js" async="" custom-element="amp-auto-ads"></script><script type="text/javascript" src="https://cdn.ampproject.org/v0/amp-bind-0.1.js" id="amp-bind-js" async custom-element="amp-bind"></script><script src="https://cdn.ampproject.org/v0/amp-facebook-0.1.js" async="" custom-element="amp-facebook"></script><script src="https://cdn.ampproject.org/v0/amp-form-0.1.js" async="" custom-element="amp-form"></script><script src="https://cdn.ampproject.org/v0/amp-iframe-0.1.js" async="" custom-element="amp-iframe"></script><script src="https://cdn.ampproject.org/v0/amp-install-serviceworker-0.1.js" async="" custom-element="amp-install-serviceworker"></script><script src="https://cdn.ampproject.org/v0/amp-sidebar-0.1.js" async="" custom-element="amp-sidebar"></script><script src="https://cdn.ampproject.org/v0/amp-social-share-0.1.js" async="" custom-element="amp-social-share"></script><script src="https://cdn.ampproject.org/v0/amp-youtube-0.1.js" async="" custom-element="amp-youtube"></script><link rel="icon" href="https://mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1-80x80.jpg" sizes="32x32"><link rel="icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&amp;ssl=1" sizes="192x192"><link crossorigin="anonymous" rel="stylesheet" id="newspack-joseph-fonts-css" href="https://fonts.googleapis.com/css?family=Old+Standard+TT%3A400%2C400i%2C700%7CEB+Garamond%3A400%2C400i%2C700%2C700i&amp;subset=latin%2Clatin-ext&amp;display=swap" type="text/css" media="all"><link crossorigin="anonymous" rel="stylesheet" id="newspack-font-import-css" href="https://fonts.googleapis.com/css?family=Baloo+Thambi+2:400,500,600,700,800&amp;display=swap" type="text/css" media="all"><style amp-custom="">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</style><link rel="profile" href="https://gmpg.org/xfn/11"><!-- This site is optimized with the Yoast SEO plugin v15.2.1 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/"><script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://mbu.ug/#organization","name":"Mbu","url":"https://mbu.ug/","sameAs":["https://www.facebook.com/mbu.ug","https://www.instagram.com/mbu.ug/","https://www.youtube.com/channel/UCPNY4Tb3k9PJGfr-zzzfPFg","https://twitter.com/MBU"],"logo":{"@type":"ImageObject","@id":"https://mbu.ug/#logo","inLanguage":"en-US","url":"https://i2.wp.com/mbu.ug/wp-content/uploads/2020/02/mbu-logo1-01.png?fit=2481%2C1084&ssl=1","width":2481,"height":1084,"caption":"Mbu"},"image":{"@id":"https://mbu.ug/#logo"}},{"@type":"WebSite","@id":"https://mbu.ug/#website","url":"https://mbu.ug/","name":"MBU","description":"Uganda&#039;s seriously fun stuff!","publisher":{"@id":"https://mbu.ug/#organization"},"potentialAction":[{"@type":"SearchAction","target":"https://mbu.ug/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#primaryimage","inLanguage":"en-US","url":"https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?fit=1040%2C692&ssl=1","width":1040,"height":692},{"@type":"WebPage","@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#webpage","url":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/","name":"Ykee Benda and family survive nasty accident (PHOTOS)","isPartOf":{"@id":"https://mbu.ug/#website"},"primaryImageOfPage":{"@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#primaryimage"},"datePublished":"2020-11-23T07:31:49+00:00","dateModified":"2020-11-23T07:55:43+00:00","description":"Uganda Musicians Association president Ykee Benda lives to tell the tale after he cheated death following a nasty accident.","inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/"]}]},{"@type":"Article","@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#article","isPartOf":{"@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#webpage"},"author":{"@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a"},"headline":"Ykee Benda and family survive nasty accident (PHOTOS)","datePublished":"2020-11-23T07:31:49+00:00","dateModified":"2020-11-23T07:55:43+00:00","mainEntityOfPage":{"@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#webpage"},"commentCount":0,"publisher":{"@id":"https://mbu.ug/#organization"},"image":{"@id":"https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#primaryimage"},"keywords":"accident,Ykee Benda","articleSection":"News","inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/#respond"]}]},{"@type":"Person","@id":"https://mbu.ug/#/schema/person/e6992d7fc44a651faaa9b2d48f8c006a","name":"Josh Ruby","image":{"@type":"ImageObject","@id":"https://mbu.ug/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=96&d=mm&r=g","caption":"Josh Ruby"},"description":"Simple, Patient, Articulate; but all with a limit. I love writing, reading, interacting with anyone with leads in Ugandan entertainment news.","sameAs":["http://www.mbu.ug","https://www.facebook.com/josh.ruby","https://www.instagram.com/iamjoshruby/","https://twitter.com/iamjoshruby","https://www.youtube.com/channel/UCMZgCJ0KrQb7JBKobh2OjvQ","https://www.tumblr.com/blog/joshruby"]}]}</script><!-- / Yoast SEO plugin. --><link rel="alternate" type="application/rss+xml" title="MBU » Feed" href="https://mbu.ug/feed/"><link rel="alternate" type="application/rss+xml" title="MBU » Comments Feed" href="https://mbu.ug/comments/feed/"><link rel="alternate" type="application/rss+xml" title="MBU » Ykee Benda and family survive nasty accident (PHOTOS) Comments Feed" href="https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/feed/"><link rel="https://api.w.org/" href="https://mbu.ug/wp-json/"><link rel="alternate" type="application/json" href="https://mbu.ug/wp-json/wp/v2/posts/70105"><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mbu.ug/xmlrpc.php?rsd"><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mbu.ug/wp-includes/wlwmanifest.xml"><link rel="shortlink" href="https://mbu.ug/?p=70105"><!-- Custom Logo: hide header text --><link rel="alternate" type="application/json+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F11%2F23%2Fykee-benda-survives-nasty-accident-photos%2F"><link rel="alternate" type="text/xml+oembed" href="https://mbu.ug/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbu.ug%2F2020%2F11%2F23%2Fykee-benda-survives-nasty-accident-photos%2F&amp;format=xml"><script id="amp-access" type="application/json">
			{"namespace":"popups","authorization":"https:\/\/mbu.ug\/wp-content\/plugins\/newspack-popups\/includes\/..\/api\/campaigns\/index.php?cid=CLIENT_ID(newspack-cid)&popups=[]&settings={\"suppress_newsletter_campaigns\":true,\"suppress_all_newsletter_campaigns_if_one_dismissed\":true,\"suppress_donation_campaigns_if_donor\":false,\"newspack_newsletters_non_interative_mode\":false}&visit={\"post_id\":\"70105\",\"categories\":\"419\",\"is_post\":true}","noPingback":true}		</script><link rel="manifest" href="https://mbu.ug/wp-json/wp/v2/web-app-manifest"><link rel="apple-touch-startup-image" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=192%2C192&amp;ssl=1"><link rel="apple-touch-icon" href="https://i0.wp.com/mbu.ug/wp-content/uploads/2017/12/cropped-favicon-1.jpg?fit=180%2C180&amp;ssl=1"></head>

<body class="post-template-default single single-post postid-70105 single-format-standard wp-custom-logo wp-embed-responsive singular hide-homepage-title hide-site-tagline h-nsub h-sb h-cl h-dh has-sidebar has-featured-image single-featured-image-default">
<amp-auto-ads type="adsense" data-ad-client="ca-pub-0521644691090227" class="i-amphtml-layout-container" i-amphtml-layout="container"></amp-auto-ads>	<amp-sidebar id="mobile-sidebar" layout="nodisplay" side="right" class="mobile-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>

		
<form role="search" method="get" class="search-form" action="https://mbu.ug/" target="_top">
	<label for="search-form-1">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-1" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	<nav class="main-navigation nav1 dd-menu" aria-label="Top Menu" toolbar-target="site-navigation" toolbar="(min-width: 767px)">
		<ul id="menu-my-nav" class="main-menu"><li id="menu-item-68286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-68286"><a href="https://mbu.ug/">Home</a></li>
<li id="menu-item-68285" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68285"><a href="https://mbu.ug/music/">Music</a></li>
<li id="menu-item-68525" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68525"><a href="https://mbu.ug/lifestyle/">Lifestyle</a></li>
<li id="menu-item-68605" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-68605"><a href="https://mbu.ug/videos/">Videos</a></li>
<li id="menu-item-69234" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-69234"><a href="https://mbu.ug/news/">News</a></li>
</ul>	</nav>
	<nav class="social-navigation" aria-label="Social Links Menu" toolbar="(min-width: 767px)" toolbar-target="social-nav-contain">
		<ul id="menu-social" class="social-links-menu"><li id="menu-item-4692" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a target="_blank" rel="noopener noreferrer" href="https://facebook.com"><span class="screen-reader-text">facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li id="menu-item-4693" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com"><span class="screen-reader-text">twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li id="menu-item-68237" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68237"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/mbu.ug/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li id="menu-item-68238" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68238"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCPNY4Tb3k9PJGfr-zzzfPFg"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->

	</amp-sidebar>
	<amp-sidebar id="desktop-sidebar" layout="nodisplay" side="left" class="desktop-sidebar i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		<button class="desktop-menu-toggle" on="tap:desktop-sidebar.toggle">
			<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>			Close		</button>
<section id="custom_html-7" class="widget_text below-content widget widget_custom_html"><div class="textwidget custom-html-widget">
<!-- mbu_leaderboard -->
<ins class="adsbygoogle amp-wp-fa9aecc" data-ad-client="ca-pub-0521644691090227" data-ad-slot="5419942286" data-ad-format="auto" data-full-width-responsive="true" data-amp-original-style="display:block"></ins>
</div></section>	</amp-sidebar>

<div id="page" class="site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	<header id="masthead" class="site-header hide-header-search" data-amp-bind-class="searchVisible ? 'show-header-search site-header ' : 'hide-header-search site-header'">

					
			<div class="middle-header-contain">
				<div class="wrapper">
					
											<div id="social-nav-contain" class="desktop-only">
													</div>
					
					
					<div class="site-branding">

	
		<a href="https://mbu.ug/" class="custom-logo-link" rel="home"><amp-img noloading="" width="2481" height="1084" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="MBU" srcset="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?w=2481&amp;ssl=1 2481w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=448%2C196&amp;ssl=1 448w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=738%2C322&amp;ssl=1 738w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=768%2C336&amp;ssl=1 768w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1536%2C671&amp;ssl=1 1536w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=2048%2C895&amp;ssl=1 2048w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1200%2C524&amp;ssl=1 1200w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1568%2C685&amp;ssl=1 1568w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?w=2340&amp;ssl=1 2340w" sizes="(max-width: 2481px) 100vw, 2481px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzEwODQnIHdpZHRoPScyNDgxJyB4bWxucz0naHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmcnIHZlcnNpb249JzEuMScvPg=="></i-amphtml-sizer><noscript><img width="2481" height="1084" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?fit=2481%2C1084&amp;ssl=1" class="custom-logo" alt="MBU" srcset="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?w=2481&amp;ssl=1 2481w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=448%2C196&amp;ssl=1 448w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=738%2C322&amp;ssl=1 738w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=768%2C336&amp;ssl=1 768w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1536%2C671&amp;ssl=1 1536w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=2048%2C895&amp;ssl=1 2048w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1200%2C524&amp;ssl=1 1200w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?resize=1568%2C685&amp;ssl=1 1568w, https://i0.wp.com/mbu.ug/wp-content/uploads/2020/10/mbu-logo1-02.png?w=2340&amp;ssl=1 2340w" sizes="(max-width: 2481px) 100vw, 2481px"></noscript></amp-img></a>
	<div class="site-identity">
											<p class="site-title"><a href="https://mbu.ug/" rel="home">MBU</a></p>
					
						<p class="site-description">
					Uganda's seriously fun stuff!				</p>
			</div><!-- .site-identity -->

</div><!-- .site-branding -->

					

					<div class="nav-wrapper desktop-only">
						<div id="tertiary-nav-contain">
													</div><!-- #tertiary-nav-contain -->

						
<div class="header-search-contain">
	<button id="search-toggle" on="tap:AMP.setState( { searchVisible: !searchVisible } ), search-form-2.focus" aria-controls="search-menu" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		<span class="screen-reader-text" data-amp-bind-text="searchVisible ? 'Close Search' : 'Open Search'">
			Open Search		</span>
		<span class="search-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
		<span class="close-icon"><svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M19 6.41L17.59 5 12 10.59 6.41 5 5 6.41 10.59 12 5 17.59 6.41 19 12 13.41 17.59 19 19 17.59 13.41 12z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg></span>
	</button>
	<div id="header-search" data-amp-bind-aria-expanded="searchVisible ? 'true' : 'false'" aria-expanded="false">
		
<form role="search" method="get" class="search-form" action="https://mbu.ug/" target="_top">
	<label for="search-form-2">
		<span class="screen-reader-text">Search for:</span>
	</label>
	<input type="search" id="search-form-2" class="search-field" placeholder="Search …" value="" name="s">
	<button type="submit" class="search-submit">
		<svg class="svg-icon" width="28" height="28" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M15.5 14h-.79l-.28-.27C15.41 12.59 16 11.11 16 9.5 16 5.91 13.09 3 9.5 3S3 5.91 3 9.5 5.91 16 9.5 16c1.61 0 3.09-.59 4.23-1.57l.27.28v.79l5 4.99L20.49 19l-4.99-5zm-6 0C7.01 14 5 11.99 5 9.5S7.01 5 9.5 5 14 7.01 14 9.5 11.99 14 9.5 14z"></path><path d="M0 0h24v24H0z" fill="none"></path></svg>		<span class="screen-reader-text">
			Search		</span>
	</button>
</form>
	</div><!-- #header-search -->
</div><!-- .header-search-contain -->
					</div><!-- .nav-wrapper -->

					
					
											<button class="mobile-menu-toggle" on="tap:mobile-sidebar.toggle">
							<svg class="svg-icon" width="20" height="20" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M3 18h18v-2H3v2zm0-5h18v-2H3v2zm0-7v2h18V6H3z"></path></svg>							<span>Menu</span>
						</button>
					
				</div><!-- .wrapper -->
			</div><!-- .middle-header-contain -->


							<div class="bottom-header-contain desktop-only">
					<div class="wrapper">
						<div id="site-navigation">
													</div>

											</div><!-- .wrapper -->
				</div><!-- .bottom-header-contain -->
					
	</header><!-- #masthead -->

	
	
	<div id="content" class="site-content">

	<section id="primary" class="content-area category-news tag-accident tag-ykee-benda">
		<main id="main" class="site-main">

								<header class="entry-header">
						
	<span class="cat-links"><span class="screen-reader-text">Posted in</span><a href="https://mbu.ug/category/news/" rel="category tag">News</a></span>		<h1 class="entry-title ">
		Ykee Benda and family survive nasty accident (PHOTOS)	</h1>
	

	<div class="entry-subhead">
					<div class="entry-meta">
				<span class="author-avatar"><amp-img alt="" src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img></span>
			<span class="byline">
				<span>by</span>
				<span class="author vcard"><a class="url fn n" href="https://mbu.ug/author/joshualubanga/">Josh Ruby</a></span> 			</span><!-- .byline -->
		<span class="posted-on"><time class="entry-date published" datetime="2020-11-23T10:31:49+03:00">November 23, 2020</time><time class="updated" datetime="2020-11-23T10:55:43+03:00">November 23, 2020</time></span>			</div><!-- .meta-info -->
				<div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon-text sd-sharing"><h3 class="sd-title">Enjoy with others:</h3><div class="sd-content"><amp-social-share type="whatsapp" height="32px" width="32px" aria-label="Click to share on WhatsApp" title="Click to share on WhatsApp" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="twitter" height="32px" width="32px" aria-label="Click to share on Twitter" title="Click to share on Twitter" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="facebook" height="32px" width="32px" aria-label="Click to share on Facebook" title="Click to share on Facebook" data-param-app_id="249643311490" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="telegram" height="32px" width="32px" aria-label="Click to share on Telegram" title="Click to share on Telegram" data-share-endpoint="https://telegram.me/share/url?url=https%3A%2F%2Fmbu.ug%2F2020%2F11%2F23%2Fykee-benda-survives-nasty-accident-photos%2F&amp;text=Ykee%20Benda%20and%20family%20survive%20nasty%20accident%20%28PHOTOS%29" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="tumblr" height="32px" width="32px" aria-label="Click to share on Tumblr" title="Click to share on Tumblr" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share><amp-social-share type="linkedin" height="32px" width="32px" aria-label="Click to share on LinkedIn" title="Click to share on LinkedIn" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:32px;height:32px;" i-amphtml-layout="fixed"></amp-social-share></div></div></div>	</div>
					</header>

				
				<div class="main-content">

					
			<figure class="post-thumbnail">

				<amp-img width="1040" height="692" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?fit=1040%2C692&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?w=1040&amp;ssl=1 1040w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=448%2C298&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=768%2C511&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=738%2C491&amp;ssl=1 738w" sizes="(max-width: 1040px) 100vw, 1040px" layout="intrinsic" disable-inline-width="" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzY5Micgd2lkdGg9JzEwNDAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img width="1040" height="692" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?fit=1040%2C692&amp;ssl=1" class="attachment-newspack-featured-image size-newspack-featured-image wp-post-image" alt="" loading="lazy" srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?w=1040&amp;ssl=1 1040w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=448%2C298&amp;ssl=1 448w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=768%2C511&amp;ssl=1 768w, https://i2.wp.com/mbu.ug/wp-content/uploads/2019/03/WhatsApp-Image-2019-03-29-at-23.02.43.jpeg?resize=738%2C491&amp;ssl=1 738w" sizes="(max-width: 1040px) 100vw, 1040px"></noscript></amp-img>
			</figure><!-- .post-thumbnail -->

		
<article id="post-70105" class="post-70105 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-accident tag-ykee-benda entry">
	<div class="entry-content">

		
		
<p class="has-drop-cap">Mpaka Records CEO and Uganda Musicians Association president Ykee Benda lives to tell the tale after he cheated death following a nasty accident.</p>



<p>On Monday morning, the <a rel="noreferrer noopener" href="https://mbu.ug/2020/10/25/ykee-benda-deep-in-love-on-ma-bebe-video/" target="_blank"><span class="has-inline-color amp-wp-3b7b5b8" data-amp-original-style="color:#ff0004">Ma Bebe</span></a> singer shared photos of himself in terrible state and the damaged car in which he got the accident.</p>



<p>With his face stitched up and not in the best shape, Ykee thanked God for giving him another chance to live with the photos shared on his social media.</p><aside class="scaip scaip-1    "><aside id="newspack-ads-widget-4" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-mbu-web-5fbbc783cc2dd-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/mbu-web" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-mbu-web-5fbbc783cc2dd-300x300"><amp-ad width="300px" height="300px" type="doubleclick" data-slot="/21882621445/mbu-web" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:300px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside>



<figure class="wp-block-image alignfull size-full"><amp-img width="576" height="1024" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?resize=576%2C1024&amp;ssl=1" alt="" class="wp-image-70106 amp-wp-enforced-sizes i-amphtml-layout-responsive i-amphtml-layout-size-defined" srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?w=576&amp;ssl=1 576w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?resize=448%2C796&amp;ssl=1 448w" sizes="(max-width: 576px) 100vw, 576px" layout="responsive" disable-inline-width="" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:177.7778%;"></i-amphtml-sizer><noscript><img loading="lazy" width="576" height="1024" src="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?resize=576%2C1024&amp;ssl=1" alt="" class="wp-image-70106" srcset="https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?w=576&amp;ssl=1 576w, https://i2.wp.com/mbu.ug/wp-content/uploads/2020/11/20201123_101754.jpg?resize=448%2C796&amp;ssl=1 448w" sizes="(max-width: 576px) 100vw, 576px"></noscript></amp-img></figure>



<p class="has-text-align-center"><strong>Read Also: </strong><a href="https://mbu.ug/2020/11/18/ykee-benda-shows-off-beautiful-family-photo/" target="_blank" rel="noreferrer noopener"><span class="has-inline-color has-primary-color">Ykee Benda shows off beautiful family</span></a></p>



<p>The singer revealed that he was travelling with his family; his son Dante Quain and wife Julie Batenga, when they got the accident.</p>



<blockquote class="wp-block-quote"><p>Got an accident with my family my son Dante &amp; his mother Julie Batenga who didn’t get any problem. We thank God for a second chance.</p><aside class="scaip scaip-2    "><aside id="newspack-ads-widget-5" class="widget_newspack-ads-widget clearfix"><div class="textwidget"><div id="div-gpt-amp-mbu-web-5fbbc783cc58c-300x250"><amp-ad width="300px" height="250px" type="doubleclick" data-slot="/21882621445/mbu-web" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div> <div id="div-gpt-amp-mbu-web-5fbbc783cc58c-300x300"><amp-ad width="300px" height="300px" type="doubleclick" data-slot="/21882621445/mbu-web" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:300px;" i-amphtml-layout="fixed"></amp-ad></div></div></aside></aside><cite>Ykee Benda</cite></blockquote>



<figure class="wp-block-embed-facebook alignfull wp-block-embed is-type-rich is-provider-embed-handler"><div class="wp-block-embed__wrapper">
<amp-facebook width="552" height="400" data-href="https://www.facebook.com/769757869713487/posts/3821226064566637/?sfnsn=mo" data-embed-as="post" layout="responsive" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:72.4638%;"></i-amphtml-sizer></amp-facebook>
</div></figure>



<p>We wish him a quick recovery!</p>

<nav class="jp-relatedposts-i2" data-layout="grid"><h3 class="jp-relatedposts-headline"><em>Related</em></h3><div class="jp-related-posts-i2__row" data-post-count="3"><ul id="related-posts-item-5fbbc783ce58a" aria-labelledby="related-posts-item-5fbbc783ce58a-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fbbc783ce58a-label" href="https://mbu.ug/2018/11/23/girlfriend-gifts-ykee-benda-with-2000-watch/">Girlfriend gifts Ykee Benda with $2000 watch</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://mbu.ug/2018/11/23/girlfriend-gifts-ykee-benda-with-2000-watch/"><amp-img src="https://i1.wp.com/mbu.ug/wp-content/uploads/2018/11/hghg.png?fit=479%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i1.wp.com/mbu.ug/wp-content/uploads/2018/11/hghg.png?fit=479%2C600&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">November 23, 2018</li><li class="jp-related-posts-i2__post-context">In "Fashion"</li></ul><ul id="related-posts-item-5fbbc783ce5bb" aria-labelledby="related-posts-item-5fbbc783ce5bb-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fbbc783ce5bb-label" href="https://mbu.ug/2018/10/08/ykee-benda-wins-2018-afrimma-award/">Ykee Benda wins big at 2018 AFRIMMA awards</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://mbu.ug/2018/10/08/ykee-benda-wins-2018-afrimma-award/"><amp-img src="https://i2.wp.com/mbu.ug/wp-content/uploads/2018/10/40161746_2060310570658204_8895384063272026112_o-e1538977792390.jpg?fit=1079%2C880&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i2.wp.com/mbu.ug/wp-content/uploads/2018/10/40161746_2060310570658204_8895384063272026112_o-e1538977792390.jpg?fit=1079%2C880&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">October 8, 2018</li><li class="jp-related-posts-i2__post-context">In "Music"</li></ul><ul id="related-posts-item-5fbbc783ce5dc" aria-labelledby="related-posts-item-5fbbc783ce5dc-label" class="jp-related-posts-i2__post" role="menuitem"><li class="jp-related-posts-i2__post-link"><a id="related-posts-item-5fbbc783ce5dc-label" href="https://mbu.ug/2020/11/18/ykee-benda-shows-off-beautiful-family-photo/">Ykee Benda shows off beautiful family</a></li><li class="jp-related-posts-i2__post-img-link"><a href="https://mbu.ug/2020/11/18/ykee-benda-shows-off-beautiful-family-photo/"><amp-img src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/11/ykeebenda_20201118_102952.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class="amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzIwMCcgd2lkdGg9JzM1MCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/11/ykeebenda_20201118_102952.jpg?fit=1080%2C720&amp;ssl=1&amp;resize=350%2C200" width="350" alt="" height="200" class=""></noscript></amp-img></a></li><li class="jp-related-posts-i2__post-date">November 18, 2020</li><li class="jp-related-posts-i2__post-context">In "Lifestyle"</li></ul></div></nav>	</div><!-- .entry-content -->

	<footer class="entry-footer">
		<span class="tags-links"><span>Tagged: </span><a href="https://mbu.ug/tag/accident/" rel="tag">accident</a><span class="sep">, </span><a href="https://mbu.ug/tag/ykee-benda/" rel="tag">Ykee Benda</a></span>	</footer><!-- .entry-footer -->

	
			<div class="author-bio">
				<amp-img alt="" src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" height="80" width="80" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzgwJyB3aWR0aD0nODAnIHhtbG5zPSdodHRwOi8vd3d3LnczLm9yZy8yMDAwL3N2ZycgdmVyc2lvbj0nMS4xJy8+"></i-amphtml-sizer><noscript><img alt="" src="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=80&amp;d=mm&amp;r=g" srcset="https://secure.gravatar.com/avatar/8e0af72e9c76f41bbba11a7cef56ec1f?s=160&amp;d=mm&amp;r=g 2x" class="avatar avatar-80 photo" height="80" width="80"></noscript></amp-img>
				<div class="author-bio-text">
					<div class="author-bio-header">
						<div>
							<h2 class="accent-header">
								Josh Ruby								<span></span>
							</h2>

															<div class="author-meta">
																			<a class="author-email" href="mailto:josh@mbu.ug">
											<svg class="svg-icon" width="18" height="18" aria-hidden="true" role="img" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 24 24"><path d="M0 0h24v24H0z" fill="none"></path><path d="M20 4H4c-1.1 0-1.99.9-1.99 2L2 18c0 1.1.9 2 2 2h16c1.1 0 2-.9 2-2V6c0-1.1-.9-2-2-2zm0 14H4V8l8 5 8-5v10zm-8-7L4 6h16l-8 5z"></path></svg>											josh@mbu.ug										</a>
																		<ul class="author-social-links"><li class="facebook"><a href="https://www.facebook.com/josh.ruby" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path><title>facebook</title></svg></a></li><li class="twitter"><a href="https://twitter.com/iamjoshruby" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path><title>twitter</title></svg></a></li><li class="instagram"><a href="https://www.instagram.com/iamjoshruby/" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path><title>instagram</title></svg></a></li><li class="tumblr"><a href="https://www.tumblr.com/blog/joshruby" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M16.749,17.396c-0.357,0.17-1.041,0.319-1.551,0.332c-1.539,0.041-1.837-1.081-1.85-1.896V9.847h3.861V6.937h-3.847V2.039 c0,0-2.77,0-2.817,0c-0.046,0-0.127,0.041-0.138,0.144c-0.165,1.499-0.867,4.13-3.783,5.181v2.484h1.945v6.282 c0,2.151,1.587,5.206,5.775,5.135c1.413-0.024,2.982-0.616,3.329-1.126L16.749,17.396z"></path><title>tumblr</title></svg></a></li><li class="youtube"><a href="https://www.youtube.com/channel/UCMZgCJ0KrQb7JBKobh2OjvQ" target="_blank"><svg class="svg-icon" width="24" height="24" aria-hidden="true" role="img" viewbox="0 0 24 24" xmlns="http://www.w3.org/2000/svg"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path><title>youtube</title></svg></a></li></ul>								</div><!-- .author-meta -->
							
						</div>
					</div><!-- .author-bio-header -->

											<p>
							Simple, Patient, Articulate; but all with a limit. I love writing, reading, interacting with anyone with leads in Ugandan entertainment news.							<a class="author-link" href="https://mbu.ug/author/joshualubanga/" rel="author">
							More by Josh Ruby							</a>
						</p>
					
				</div><!-- .author-bio-text -->

			</div><!-- .author-bio -->
		
</article><!-- #post-${ID} -->

<div id="comments" class="comments-area">
	<div class="comments-title-wrap no-responses">
		<h2 class="comments-title">
		Leave a comment		</h2><!-- .comments-title -->
			</div><!-- .comments-title-flex -->
		
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">					<small><a id="cancel-comment-reply-link" href="/2020/11/23/ykee-benda-survives-nasty-accident-photos/#respond" hidden data-amp-bind-hidden='commentform_post_70105.values.comment_parent == "0"' on='tap:AMP.setState( {"commentform_post_70105":{"replyToName":"","values":{"comment_parent":"0"}}} )'>Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form" method="get" action="//mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/" target="_top">
				<amp-iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&amp;postid=70105&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=1&amp;stb_enabled=1&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=9.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=f0020f65bcb27f3975ca3cf11ef79895d633bc70#parent=https%3A%2F%2Fmbu.ug%2F2020%2F11%2F23%2Fykee-benda-survives-nasty-accident-photos%2F" resizable="" layout="fixed-height" height="430" class="jetpack_remote_comment i-amphtml-layout-fixed-height i-amphtml-layout-size-defined" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups" style="height:430px;" i-amphtml-layout="fixed-height"><span placeholder="" class="amp-wp-iframe-placeholder"></span><button overflow>Show more</button><noscript><iframe title="Comment Form" src="https://jetpack.wordpress.com/jetpack-comment/?blogid=140035613&amp;postid=70105&amp;comment_registration=0&amp;require_name_email=1&amp;stc_enabled=1&amp;stb_enabled=1&amp;show_avatars=1&amp;avatar_default=mystery&amp;greeting=&amp;greeting_reply=Leave+a+Reply+to+%25s&amp;color_scheme=light&amp;lang=en_US&amp;jetpack_version=9.1&amp;show_cookie_consent=10&amp;has_cookie_consent=0&amp;token_key=%3Bnormal%3B&amp;sig=f0020f65bcb27f3975ca3cf11ef79895d633bc70#parent=https%3A%2F%2Fmbu.ug%2F2020%2F11%2F23%2Fykee-benda-survives-nasty-accident-photos%2F" resizable height="430" class="jetpack_remote_comment" id="jetpack_remote_comment" sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups">
											
									</iframe></noscript></amp-iframe>
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="">

		</div><!-- #comments -->
				</div><!-- .main-content -->

			
<aside id="secondary" class="widget-area">
	<section id="newspack-ads-widget-2" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/mbu-sidebar-one" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section><section id="media_video-2" class="widget widget_media_video"><amp-youtube data-videoid="YIL_rr6C76c" layout="responsive" width="600" height="338" class="i-amphtml-layout-responsive i-amphtml-layout-size-defined" i-amphtml-layout="responsive"><i-amphtml-sizer style="display:block;padding-top:56.3333%;"></i-amphtml-sizer></amp-youtube></section>
		<section id="recent-posts-5" class="widget widget_recent_entries">
		<h2 class="widget-title accent-header"><span>Latest</span></h2>
		<ul>
											<li>
					<a href="https://mbu.ug/2020/11/23/eezzy-lilian-mbabazi-and-shaka-mao-set-for-club-beatz-concert/">Eezzy, Lilian Mbabazi and Shaka Mao set for Club Beatz concert</a>
									</li>
											<li>
					<a href="https://mbu.ug/2020/11/23/gospel-singer-johnmarie-introduced-by-longtime-lover-jackie-photos/">Gospel singer JohnMarie introduced by longtime lover Jackie (Photos)</a>
									</li>
											<li>
					<a href="https://mbu.ug/2020/11/23/a-pass-leaves-girls-yearning-for-him-with-video-showing-his-bulged-groin/">A Pass leaves girls yearning for him with video showing his bulged groin</a>
									</li>
											<li>
					<a href="https://mbu.ug/2020/11/23/ykee-benda-survives-nasty-accident-photos/" aria-current="page">Ykee Benda and family survive nasty accident (PHOTOS)</a>
									</li>
											<li>
					<a href="https://mbu.ug/2020/11/22/alex-muhangi-releases-new-song-dubbed-kunyumirwa/">Alex Muhangi releases new song dubbed Kunyumirwa</a>
									</li>
					</ul>

		</section><section id="newspack-ads-widget-3" class="widget widget_newspack-ads-widget"><div class="textwidget"><amp-ad width="300" height="250" type="doubleclick" data-slot="/21882621445/mbu_sidebar_two" data-loading-strategy="prefer-viewability-over-views" json='{"targeting":{"slug":"ykee-benda-survives-nasty-accident-photos","category":["news"],"ID":70105}}' class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:300px;height:250px;" i-amphtml-layout="fixed"></amp-ad></div></section></aside><!-- #secondary -->

		</main><!-- #main -->
	</section><!-- #primary -->


	
	</div><!-- #content -->

	<footer id="colophon" class="site-footer">

					<div class="footer-branding">
		<div class="wrapper">
							<a class="footer-logo-link" href="https://mbu.ug/" rel="home">
					<amp-img width="400" height="174" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/02/cropped-mbu-logo1-01.png?resize=400%2C174&amp;ssl=1" class="footer-logo amp-wp-enforced-sizes i-amphtml-layout-intrinsic i-amphtml-layout-size-defined" alt="" layout="intrinsic" i-amphtml-layout="intrinsic"><i-amphtml-sizer class="i-amphtml-sizer"><img alt="" aria-hidden="true" class="i-amphtml-intrinsic-sizer" role="presentation" src="data:image/svg+xml;base64,PHN2ZyBoZWlnaHQ9JzE3NCcgd2lkdGg9JzQwMCcgeG1sbnM9J2h0dHA6Ly93d3cudzMub3JnLzIwMDAvc3ZnJyB2ZXJzaW9uPScxLjEnLz4="></i-amphtml-sizer><noscript><img width="400" height="174" src="https://i0.wp.com/mbu.ug/wp-content/uploads/2020/02/cropped-mbu-logo1-01.png?resize=400%2C174&amp;ssl=1" class="footer-logo" alt="" loading="lazy"></noscript></amp-img>				</a>
				<nav class="social-navigation" aria-label="Social Links Menu">
		<ul id="menu-social-1" class="social-links-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4692"><a target="_blank" rel="noopener noreferrer" href="https://facebook.com"><span class="screen-reader-text">facebook</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12 2C6.5 2 2 6.5 2 12c0 5 3.7 9.1 8.4 9.9v-7H7.9V12h2.5V9.8c0-2.5 1.5-3.9 3.8-3.9 1.1 0 2.2.2 2.2.2v2.5h-1.3c-1.2 0-1.6.8-1.6 1.6V12h2.8l-.4 2.9h-2.3v7C18.3 21.1 22 17 22 12c0-5.5-4.5-10-10-10z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-4693"><a target="_blank" rel="noopener noreferrer" href="https://twitter.com"><span class="screen-reader-text">twitter</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M22.23,5.924c-0.736,0.326-1.527,0.547-2.357,0.646c0.847-0.508,1.498-1.312,1.804-2.27 c-0.793,0.47-1.671,0.812-2.606,0.996C18.324,4.498,17.257,4,16.077,4c-2.266,0-4.103,1.837-4.103,4.103 c0,0.322,0.036,0.635,0.106,0.935C8.67,8.867,5.647,7.234,3.623,4.751C3.27,5.357,3.067,6.062,3.067,6.814 c0,1.424,0.724,2.679,1.825,3.415c-0.673-0.021-1.305-0.206-1.859-0.513c0,0.017,0,0.034,0,0.052c0,1.988,1.414,3.647,3.292,4.023 c-0.344,0.094-0.707,0.144-1.081,0.144c-0.264,0-0.521-0.026-0.772-0.074c0.522,1.63,2.038,2.816,3.833,2.85 c-1.404,1.1-3.174,1.756-5.096,1.756c-0.331,0-0.658-0.019-0.979-0.057c1.816,1.164,3.973,1.843,6.29,1.843 c7.547,0,11.675-6.252,11.675-11.675c0-0.178-0.004-0.355-0.012-0.531C20.985,7.47,21.68,6.747,22.23,5.924z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68237"><a target="_blank" rel="noopener noreferrer" href="https://www.instagram.com/mbu.ug/"><span class="screen-reader-text">Instagram</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M12,4.622c2.403,0,2.688,0.009,3.637,0.052c0.877,0.04,1.354,0.187,1.671,0.31c0.42,0.163,0.72,0.358,1.035,0.673 c0.315,0.315,0.51,0.615,0.673,1.035c0.123,0.317,0.27,0.794,0.31,1.671c0.043,0.949,0.052,1.234,0.052,3.637 s-0.009,2.688-0.052,3.637c-0.04,0.877-0.187,1.354-0.31,1.671c-0.163,0.42-0.358,0.72-0.673,1.035 c-0.315,0.315-0.615,0.51-1.035,0.673c-0.317,0.123-0.794,0.27-1.671,0.31c-0.949,0.043-1.233,0.052-3.637,0.052 s-2.688-0.009-3.637-0.052c-0.877-0.04-1.354-0.187-1.671-0.31c-0.42-0.163-0.72-0.358-1.035-0.673 c-0.315-0.315-0.51-0.615-0.673-1.035c-0.123-0.317-0.27-0.794-0.31-1.671C4.631,14.688,4.622,14.403,4.622,12 s0.009-2.688,0.052-3.637c0.04-0.877,0.187-1.354,0.31-1.671c0.163-0.42,0.358-0.72,0.673-1.035 c0.315-0.315,0.615-0.51,1.035-0.673c0.317-0.123,0.794-0.27,1.671-0.31C9.312,4.631,9.597,4.622,12,4.622 M12,3 C9.556,3,9.249,3.01,8.289,3.054C7.331,3.098,6.677,3.25,6.105,3.472C5.513,3.702,5.011,4.01,4.511,4.511 c-0.5,0.5-0.808,1.002-1.038,1.594C3.25,6.677,3.098,7.331,3.054,8.289C3.01,9.249,3,9.556,3,12c0,2.444,0.01,2.751,0.054,3.711 c0.044,0.958,0.196,1.612,0.418,2.185c0.23,0.592,0.538,1.094,1.038,1.594c0.5,0.5,1.002,0.808,1.594,1.038 c0.572,0.222,1.227,0.375,2.185,0.418C9.249,20.99,9.556,21,12,21s2.751-0.01,3.711-0.054c0.958-0.044,1.612-0.196,2.185-0.418 c0.592-0.23,1.094-0.538,1.594-1.038c0.5-0.5,0.808-1.002,1.038-1.594c0.222-0.572,0.375-1.227,0.418-2.185 C20.99,14.751,21,14.444,21,12s-0.01-2.751-0.054-3.711c-0.044-0.958-0.196-1.612-0.418-2.185c-0.23-0.592-0.538-1.094-1.038-1.594 c-0.5-0.5-1.002-0.808-1.594-1.038c-0.572-0.222-1.227-0.375-2.185-0.418C14.751,3.01,14.444,3,12,3L12,3z M12,7.378 c-2.552,0-4.622,2.069-4.622,4.622S9.448,16.622,12,16.622s4.622-2.069,4.622-4.622S14.552,7.378,12,7.378z M12,15 c-1.657,0-3-1.343-3-3s1.343-3,3-3s3,1.343,3,3S13.657,15,12,15z M16.804,6.116c-0.596,0-1.08,0.484-1.08,1.08 s0.484,1.08,1.08,1.08c0.596,0,1.08-0.484,1.08-1.08S17.401,6.116,16.804,6.116z"></path></svg></a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-68238"><a target="_blank" rel="noopener noreferrer" href="https://www.youtube.com/channel/UCPNY4Tb3k9PJGfr-zzzfPFg"><span class="screen-reader-text">Youtube</span><svg class="svg-icon" width="26" height="26" aria-hidden="true" role="img" focusable="false" viewbox="0 0 24 24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><path d="M21.8,8.001c0,0-0.195-1.378-0.795-1.985c-0.76-0.797-1.613-0.801-2.004-0.847c-2.799-0.202-6.997-0.202-6.997-0.202 h-0.009c0,0-4.198,0-6.997,0.202C4.608,5.216,3.756,5.22,2.995,6.016C2.395,6.623,2.2,8.001,2.2,8.001S2,9.62,2,11.238v1.517 c0,1.618,0.2,3.237,0.2,3.237s0.195,1.378,0.795,1.985c0.761,0.797,1.76,0.771,2.205,0.855c1.6,0.153,6.8,0.201,6.8,0.201 s4.203-0.006,7.001-0.209c0.391-0.047,1.243-0.051,2.004-0.847c0.6-0.607,0.795-1.985,0.795-1.985s0.2-1.618,0.2-3.237v-1.517 C22,9.62,21.8,8.001,21.8,8.001z M9.935,14.594l-0.001-5.62l5.404,2.82L9.935,14.594z"></path></svg></a></li>
</ul>	</nav><!-- .social-navigation -->
		</div><!-- .wrapper -->
	</div><!-- .footer-branding -->
		
	<aside class="widget-area footer-widgets" role="complementary" aria-label="Footer">
		<div class="wrapper">
					</div><!-- .wrapper -->
	</aside><!-- .widget-area -->


		<div class="site-info">

			
			<div class="wrapper site-info-contain">
													<span class="copyright">© 2020 All Rights reserved. Mbu is a division of OWINO SOLUTIONS.</span>
				
				<a href="https://newspack.pub/" class="imprint">
					Proudly powered by Newspack by Automattic				</a>

							</div><!-- .wrapper -->
		</div><!-- .site-info -->
	</footer><!-- #colophon -->

</div><!-- #page -->

		<amp-install-serviceworker src="/?wp_service_worker=1" data-iframe-src="https://mbu.ug/?amp_install_service_worker_iframe=1" layout="nodisplay" class="i-amphtml-layout-nodisplay" hidden="hidden" i-amphtml-layout="nodisplay">
		</amp-install-serviceworker>
		<amp-analytics type="gtag" data-credentials="include" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"><script type="application/json">{"vars":{"gtag_id":"UA-110865138-1","config":{"UA-110865138-1":{"groups":"default","linker":[]}}},"optoutElementId":"__gaOptOutExtension","triggers":{"socialShareClickedFacebook":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"facebook","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"facebook\"]"},"socialShareClickedTwitter":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"twitter","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"twitter\"]"},"socialShareClickedWhatsApp":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"whatsapp","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"whatsapp\"]"},"socialShareClickedLinkedIn":{"request":"event","on":"click","vars":{"event_name":"social share","event_label":"linkedin","event_category":"NTG social","non_interaction":false},"selector":"amp-social-share[type=\"linkedin\"]"},"articleRead25":{"request":"event","on":"scroll","vars":{"event_name":"25%","event_label":"Ykee Benda and family survive nasty accident (PHOTOS)","event_category":"NTG article milestone","non_interaction":true,"value":25},"event_value":25,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[25]}},"articleRead50":{"request":"event","on":"scroll","vars":{"event_name":"50%","event_label":"Ykee Benda and family survive nasty accident (PHOTOS)","event_category":"NTG article milestone","non_interaction":true,"value":50},"event_value":50,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[50]}},"articleRead100":{"request":"event","on":"scroll","vars":{"event_name":"100%","event_label":"Ykee Benda and family survive nasty accident (PHOTOS)","event_category":"NTG article milestone","non_interaction":true,"value":100},"event_value":100,"non_interaction":true,"scrollSpec":{"verticalBoundaries":[100]}},"addComment":{"request":"event","on":"amp-form-submit-success","vars":{"event_name":"comment added","event_label":"Ykee Benda and family survive nasty accident (PHOTOS)","event_category":"NTG user","non_interaction":false},"selector":"#commentform"}}}</script></amp-analytics>



			<amp-analytics class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed">
				<script type="application/json">
					{"linkers":{"enabled":true,"ref_newspack_cid":{"ids":{"cid":"CLIENT_ID(newspack-cid)"}}},"cookies":{"enabled":true,"newspack-cid":{"value":"LINKER_PARAM(ref_newspack_cid, cid)"}}}				</script>
			</amp-analytics>
			<amp-pixel src="https://pixel.wp.com/g.gif?v=ext&amp;j=1%3A9.1&amp;blog=140035613&amp;post=70105&amp;tz=3&amp;srv=mbu.ug&amp;host=mbu.ug&amp;rand=RANDOM&amp;ref=DOCUMENT_REFERRER" class="i-amphtml-layout-fixed i-amphtml-layout-size-defined" style="width:1px;height:1px;" i-amphtml-layout="fixed"></amp-pixel>
	

</body></html>
